This help site has been deprecated. Please send your requests to

RubyGems Upgrade Issues

gem update --system is disabled on Debian. RubyGems can be updated using the official Debian repositories

This is due to using apt-get install rubygems. We recommend that you uninstall RubyGems via Aptitude and install it from source. Further instructions are here for doing so.

Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please gem update –system and try again.

If you have updated Rails to 2.2 or 2.3 you will see an error similar to this (depending on what version of gems you have installed). However when you try run the command ‘gem update –system’ it will fail depending on what version of gem you have installed (well it doesn’t exactly fail, it just pleasantly tells you there was nothing to install, bug if you do a gems -v, it will still be 1.2.0).

The work around is:

gem install rubygems-update

(Credit goes to Mark Howe)