This help site has been deprecated. Please send your requests to

Requiring ruby 2+ from Mina 1

Batbayar Sukhbaatar's Avatar

Batbayar Sukhbaatar

08 Nov, 2016 06:14 AM

Hello i recently installed mina gem and used it with my new project using ruby 1.9.3 and rails 3.2.13. Mina 1.0.2 and 1.0.0 are raising error which is something related to syntax when i try to initialize it with "mina init". These versions was ok with ruby 2+ when i checked it. So mentioning it in requirements would be nice. After all really appreciate for great gem.

This discussion was closed! See this FAQ for more information:

  1. RubyGems Upgrade Issues

    gem update --system is disabled on Debian. RubyGems can be updated using the official Debian repositories

    This is due to using apt-get install rubygems. We recommend that you uninstall RubyGems via Aptitude and install it from source. Further instructions are here for doing so.

    Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please gem update –system and try again.

    If you have updated Rails to ...

    See more..

Discussions are closed to public comments.
If you need help with please start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac