netaddr is abandoned

Daniel's Avatar


22 Jan, 2016 04:05 PM

did this question actually get posted? I can't find it when I search.

  1. 1 Posted by Daniel on 22 Jan, 2016 04:05 PM

    Daniel's Avatar

    did this question actually get posted? I can't find it when I search.

  2. 2 Posted by Daniel on 22 Jan, 2016 10:34 PM

    Daniel's Avatar

    Ok, original issue (not seeing it in this thread) was that netaddr has not been updated since 2008. A copy of it was placed on github by 'bensie' with some bug fixes and there is another fairly big problem with the sorted list where the cidr blocks are not fully collapsed. I can create another e.g. netaddr2 gem but it seems better to roll up bensie's fixes and my fix into the gem that nearly 1M people have downloaded.

    I have tried contacting the owner of the gem several times over the last few months but have received no response. I am hoping I can get added as a maintainer to update the gem.

  3. Support Staff 3 Posted by Nick Quaranto on 23 Jan, 2016 06:46 PM

    Nick Quaranto's Avatar

    Well I just goofed up two things:

    1) Your comment got marked as spam.
    2) I added dspinhir@yahoo 4 times.

    I just did a quick Google and I couldn't find any other emails for Dustin. Have you tried any others that I could add here? Usually we try to resolve this with the authors themselves as we have very rarely given gem access over.

  4. 4 Posted by d6crawler on 23 Jan, 2016 10:28 PM

    d6crawler's Avatar

    It looks like maybe the same guy is working at rackspace per linked-in. That is the only other lead I found. Because he is not a connection on linked in I am not sure if I can send him and email. I used to know a guy at rackspace so maybe after I fiddle around there I can get in touch that way. Have to see. Do you have a contact there?

        On Saturday, January 23, 2016 1:47 PM, Nick Quaranto <[email blocked]> wrote:

      #yiv9018574003 pre {width:92%;margin:10px 2%;padding:5px 2%;background:#efefef;border:1px solid #d6d6d6;}#yiv9018574003 blockquote {margin-left:0;padding-left:1em;border-left:5px solid #ccc;}

  5. 5 Posted by Dustin Spinhirn... on 25 Jan, 2016 02:28 PM

    Dustin Spinhirne's Avatar

    This is actually the first inquiry I've seen in years on this code. I
    left Rackspace way back in 2009 so if you've been attempting to contact
    me there then that would explain why I've not been getting your messages.

    If you've identified a bug then I'd be happy to take a look.

  6. 6 Posted by Daniel on 25 Jan, 2016 08:36 PM

    Daniel's Avatar

    It looks like the bug has been fixed with the netaddr 1.5.1 release. Thank you and also thanks Nick for helping out!


  7. Support Staff 7 Posted by Nick Quaranto on 25 Jan, 2016 08:37 PM

    Nick Quaranto's Avatar

    Nice! I'll close this out then.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac