Issues with Accessing Gems

yoon.lee's Avatar

yoon.lee

29 Aug, 2014 06:23 PM

I'm a total beginner in Ruby and I'm trying to use the 'spreadsheet' gems by calling:
require 'spreadsheet'

I'm using Ruby1.8.7 and I've downloaded the latest spreadsheet 1.0.0 online. They are currently located under the rubygems folder-- C:\Ruby187\lib\ruby\site_ruby\1.8\rubygems\spreadsheet-master

When I run the code, I keep getting a <LoadError> flagging .../rubygems/custom_require.rb:36:in 'gem_original_require': no such file to load.

My codes start with:
require 'rubygems'
require 'spreadsheet' (I've used require 'spreadsheet-master' and require 'entire path/spreadsheet.rb', etc....)

Also I've downloaded spreadsheet-1.0.0.gem from this website and tried to use the "gem install --local .gem" in the Ruby CMD, but will give me <URI::InvalidURIError>.

What would be causing this?

  1. yoon.lee closed this discussion on 02 Sep, 2014 02:27 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac