When I upload a gem out of order for versions...

ferventcoder's Avatar


23 Jul, 2010 12:47 PM

...the site shows it in the correct order. However, when I try to install the gem, it pulls down the older version (last one in). Is this by design?


Notice how 3.6 is the current version?

gem install rhino.mocks Successfully installed rhino.mocks-
1 gem installed
Installing ri documentation for rhino.mocks-
Installing RDoc documentation for rhino.mocks-

  1. 1 Posted by ferventcoder on 23 Jul, 2010 02:38 PM

    ferventcoder's Avatar

    I think this is more of a gem install issue than rubygems.org.

    It is inconsistent with what the site shows though.


  2. 2 Posted by ferventcoder on 25 Jul, 2010 01:46 PM

    ferventcoder's Avatar

    I noticed recently that this has flipped. I don't know if this was due to human intervention or if it was a daemon on the back end reordering these items?

  3. Support Staff 3 Posted by Nick Quaranto on 25 Jul, 2010 04:34 PM

    Nick Quaranto's Avatar

    When did you run gem install? It takes about a minute after pushing for the index to update with the right version.

  4. 4 Posted by ferventcoder on 25 Jul, 2010 07:06 PM

    ferventcoder's Avatar

    It was immediately after. I think a couple hours later I tried again and it was still off. But I tried again on a different day and it was fine. It could be that I was inside of some window where the indexing had just happened.

    I believe you answered the question though. The gems get reordered by version number automatically at some point in time.

  5. Nick Quaranto closed this discussion on 31 Jul, 2010 05:43 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac