Problems with gemcutter gem

Andrew Cherkashin's Avatar

Andrew Cherkashin

15 Mar, 2010 10:53 PM

So, you can see my problem below:

Successfully installed gemcutter-0.5.0
1 gem installed
Installing ri documentation for gemcutter-0.5.0...
Updating class cache with 2017 classes...
Installing RDoc documentation for gemcutter-0.5.0...
# gem tumble                                                                                                                                        5:56:12
/usr/local/lib/ruby19/gems/1.9/gems/gemcutter-0.5.0/lib/gemcutter.rb:4:in `require': no such file to load -- rubygems/commands/migrate (LoadError)
    from /usr/local/lib/ruby19/gems/1.9/gems/gemcutter-0.5.0/lib/gemcutter.rb:4:in `block in <top (required)>'
    from /usr/local/lib/ruby19/gems/1.9/gems/gemcutter-0.5.0/lib/gemcutter.rb:3:in `each'
    from /usr/local/lib/ruby19/gems/1.9/gems/gemcutter-0.5.0/lib/gemcutter.rb:3:in `<top (required)>'
    from /usr/local/lib/ruby19/gems/1.9/gems/gemcutter-0.5.0/lib/rubygems_plugin.rb:1:in `require'
    from /usr/local/lib/ruby19/gems/1.9/gems/gemcutter-0.5.0/lib/rubygems_plugin.rb:1:in `<top (required)>'
    from /usr/local/lib/ruby/site_ruby/1.9/rubygems.rb:1113:in `load'
    from /usr/local/lib/ruby/site_ruby/1.9/rubygems.rb:1113:in `block in <top (required)>'
    from /usr/local/lib/ruby/site_ruby/1.9/rubygems.rb:1105:in `each'
    from /usr/local/lib/ruby/site_ruby/1.9/rubygems.rb:1105:in `<top (required)>'
    from /usr/local/bin/gem:8:in `require'
    from /usr/local/bin/gem:8:in `<main>'
  1. Support Staff 1 Posted by Nick Quaranto on 15 Mar, 2010 11:17 PM

    Nick Quaranto's Avatar

    First of all, gem tumble is was for when gemcutter wasn't the default gem host, and now we are. :) What version of RubyGems are you on? If gem env still works that would help.

  2. 2 Posted by Andrew Cherkash... on 15 Mar, 2010 11:21 PM

    Andrew Cherkashin's Avatar

    No it doesn't work w/o deleting of "/usr/local/lib/ruby19/gems/1.9/gems/gemcutter-0.5.0/"
    Gem version: 1.3.6

    # gem env                                                                                                                                           6:28:24
    RubyGems Environment:
      - RUBYGEMS VERSION: 1.3.6
      - RUBY VERSION: 1.9.1 (2009-12-07 patchlevel 376) [i386-freebsd8]
      - INSTALLATION DIRECTORY: /usr/local/lib/ruby19/gems/1.9
      - RUBY EXECUTABLE: /usr/local/bin/ruby19
      - EXECUTABLE DIRECTORY: /usr/local/bin
        - ruby
        - x86-freebsd-8
      - GEM PATHS:
         - /usr/local/lib/ruby19/gems/1.9
         - /root/.gem/ruby/1.9
         - :update_sources => true
         - :verbose => true
         - :benchmark => false
         - :backtrace => false
         - :bulk_threshold => 1000
  3. 3 Posted by Jonathan Bryant on 17 Mar, 2010 05:58 PM

    Jonathan Bryant's Avatar

    I'm having the same problem. Same rubygems version, same error message on Ubuntu 9.10.

  4. 4 Posted by Andrew Cherkash... on 20 Mar, 2010 04:42 AM

    Andrew Cherkashin's Avatar

    I tried install it in brand new jail. So, after installing gemcutter gem - some problem.

  5. 5 Posted by troy.stribling on 22 Mar, 2010 03:35 PM

    troy.stribling's Avatar

    I also am having this problem on Ubuntu 9.10. Any usage of the gem command crashes with the error

    /usr/local/lib/ruby19/gems/1.9/gems/gemcutter-0.5.0/lib/gemcutter.rb:4:in `require': no such file to load -- rubygems/commands/migrate (LoadError)

  6. 6 Posted by troy.stribling on 23 Mar, 2010 03:59 AM

    troy.stribling's Avatar

    The problem seems to be with building gems from source and using the default install path, which I did on the first install. There were actually bigger problems than this error. The source of all problems was a screw up of the load path. If I used the rubygems1.9.1 package everything works. The build from source installs gems in a different path than the package install.

  7. 7 Posted by Jonathan Bryant on 23 Mar, 2010 01:25 PM

    Jonathan Bryant's Avatar

    The rubygems1.9.1 package installs 1.3.5, but 1.3.6 is needed for Bundler & Rails 3. My problems started after running update_rubygems. This is a, I believe, Ubuntu specific problem because gem update --system is disabled by default and rubygems-update has to be used, forcing the source install.

  8. 8 Posted by Andrey Cherkash... on 27 Apr, 2010 05:11 AM

    Andrey Cherkashin's Avatar

    No i have that problem on my Mac.

    Sent from my iPad

  9. Nick Quaranto closed this discussion on 18 Mar, 2011 09:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac