Error installing mysql2:

dan_turmacu's Avatar

dan_turmacu

09 Mar, 2020 07:07 AM

C:\Users\Asus>gem install mysql2
ERROR: Error installing mysql2:
        The last version of mysql2 (>= 0) to support your Ruby & RubyGems was 0.5.3. Try installing it with `gem install mysql2 -v 0.5.3`
        mysql2 requires Ruby version >= 2.2, < 2.7.dev. The current ruby version is 2.7.0.0.

I dont know why I get this error.

This discussion was closed! See this FAQ for more information:

  1. Why do I get HTTP Response 302 or 301 when installing a gem?

    gem install rake 
    ERROR: While executing gem ... (Gem::RemoteSourceException) 
        HTTP Response 302

    You need to upgrade RubyGems. See:

    http://rubygems.org/pages/download

    See more..
  1. dan_turmacu closed this discussion on 09 Mar, 2020 07:07 AM.

  2. dan_turmacu re-opened this discussion on 09 Mar, 2020 07:09 AM

  3. 1 Posted by dan_turmacu on 09 Mar, 2020 07:09 AM

    dan_turmacu's Avatar

    I closed it by error

  4. Support Staff 2 Posted by sonalkr132 on 23 Mar, 2020 06:08 PM

    sonalkr132's Avatar

    Hi Dan,

    This doesn't seem related to rubygems.org or the gem client. please use stackoverflow for the same.

    requires Ruby version >= 2.2, < 2.7.dev. The current ruby version is 2.7.0.0.

    your error message has the answer :)

  5. sonalkr132 closed this discussion on 23 Mar, 2020 06:08 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

20 Oct, 2020 07:13 PM
20 Oct, 2020 11:11 AM
13 Oct, 2020 06:14 PM
13 Oct, 2020 04:27 AM
06 Oct, 2020 08:22 AM