gem update --system times out

kdmiller45's Avatar

kdmiller45

09 Nov, 2019 04:07 PM

I try to perform gem update --system

ERROR: While executing gem ... (Gem::RemoteFetcher::UnknownHostError)
time out (https://rubygems.org/specs.4.8.gz

I have disabled Ip6 still happens and added google DNS's 8.8.8.8 and 8.8.4.4
I am attempting to install on Ubuntu 18.04
Thanks for the help
Keith

  1. 1 Posted by Prakhyat on 14 Nov, 2019 03:38 PM

    Prakhyat's Avatar

    Hello,

    I'm also having the same error since yesterday (nov 13th).
    Gem::RemoteFetcher::UnknownHostError: timed out (https://rubygems.org/gems/aws-sdk-connect-1.20.0.gem)

    Are there any issues in EU region?

    Thanks
    Prakhyat

  2. Support Staff 2 Posted by sonalkr132 on 28 Nov, 2019 03:34 PM

    sonalkr132's Avatar

    Hi,

    Sorry about delay in our response. We aren't aware of any issue with EU region or otherwise. Is this still not working? if so, can you please paste the output of following two commands:

    curl -vvv https://rubygems.org/specs.4.8.gz
    wget https://rubygems.org/specs.4.8.gz
    

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac