bundle install is not installing in my macbook

Kathiresan Murugan's Avatar

Kathiresan Murugan

15 Jul, 2019 07:19 AM

I have downloaded https://github.com/vector-im/riot-ios#copyright--license and follow build instructions. But when I install a bundle some errors are occurred like

An error occurred while installing unf_ext (0.0.7.6), and Bundler
cannot continue.
Make sure that `gem install unf_ext -v '0.0.7.6' --source
'https://rubygems.org/'` succeeds before bundling.

So, Then I run a gem install unf_ext -v '0.0.7.6' --source 'https://rubygems.org/'

I got this.

Building native extensions. This could take a while...
ERROR: Error installing unf_ext:
ERROR: Failed to build gem native extension.

    current directory: /Library/Ruby/Gems/2.6.0/gems/unf_ext-0.0.7.6/ext/unf_ext
/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/bin/ruby -I /Library/Ruby/Site/2.6.0 -r ./siteconf20190715-10407-1wysp9h.rb extconf.rb
mkmf.rb can't find header files for ruby at /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /Library/Ruby/Gems/2.6.0/gems/unf_ext-0.0.7.6 for inspection.
Results logged to /Library/Ruby/Gems/2.6.0/extensions/universal-darwin-19/2.6.0/unf_ext-0.0.7.6/gem_make.out

Kindly help me to run Riot-iOS on my MacBook. System version macOS Catalina 10.15 Beta (19A487m)

  1. 1 Posted by Tyler Morgan on 26 Jul, 2019 03:09 PM

    Tyler Morgan's Avatar

    I too had gotten this issue when installing a gem I use. I seem to not be able to get around this at all.

  2. 2 Posted by Tyler Morgan on 26 Jul, 2019 03:36 PM

    Tyler Morgan's Avatar

    A work around, for now, is it use "brew" and run the command "brew install ruby" then override the default path for the system ruby to the brew ruby, and you are golden.

  3. Support Staff 3 Posted by sonalkr132 on 15 Aug, 2019 07:16 PM

    sonalkr132's Avatar

    Hi,
    This doesn't seem to have anything to do with rubygems.org the website or rubygems the client. This forum is for help request for these two only, please use stackoverflow or the GitHub for help with specific libraries.

  4. sonalkr132 closed this discussion on 15 Aug, 2019 07:16 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac