This help site has been deprecated. Please send your requests to

IPv6 still broken in 2019 - please delete your AAAA records until it can be resolved

Daniel R.'s Avatar

Daniel R.

30 Jan, 2019 04:51 PM


I found this thread after a frustrating apparent "outage" which turned out to just be this same issue that's been intermittently plaguing rubygems for at least the last year: - The thread was closed with a promise of addressing it elsewhere but no indication of where to go for updates for those impacted.

I'm not asking for the maintainers of to support IPv6, but I am begging you to please just delete your AAAA records and have the hostname become ipv4 only until such time as you're willing and able to actually support ipv6 and also to add its connectivity status to the status page as well. Maintaining broken ipv6 support when the ruby HTTP client "gem" uses cannot fall back is breaking people's stuff - and ipv6 is enabled by default now on all OSs that I know of. Forcing users to disable their own ipv6 stack to get Rubygems working is also a bad solution because it means that anything people use that does need ipv6 can't use that without switching it on and off constantly.

I understand from another recent thread that the project maintainers have every reason to believe the root cause isn't with the project's own setup, but just as you would take action if large parts of the Internet were unable to reach you over ipv4 even if it was your hosting provider's fault, I'd argue the fact that much of the Internet reproducibly can't reach you on ipv6 is a real problem which needs to be solved in the short term, not just met with a "huh, that's weird, works fine for me."

There is no downside I'm aware of at this point to removing the AAAA records on this hostname - while every major OS enables ipv6 by default, none of them disable ipv4 by default so you would be making the service available for many more people by dropping the AAAA records until the issue with your upstream service providers is resolved.

  1. 1 Posted by Suny on 16 Feb, 2019 11:11 AM

    Suny's Avatar

    Pls help

  2. 2 Posted by Domon on 13 May, 2019 05:46 AM

    Domon's Avatar

    I'm experience the same issue.

    I really hope could either support IPv6 or remove the IPv6 DNS record.


    Update: I restarted my computer and it works now. 

    > ping6
    PING6(56=40+8+8 bytes) [...] --> 2a04:4e42::70
    16 bytes from 2a04:4e42::70, icmp_seq=0 hlim=55 time=47.723 ms
    16 bytes from 2a04:4e42::70, icmp_seq=1 hlim=55 time=43.885 ms
    16 bytes from 2a04:4e42::70, icmp_seq=2 hlim=55 time=43.465 ms
    16 bytes from 2a04:4e42::70, icmp_seq=3 hlim=55 time=42.693 ms
    16 bytes from 2a04:4e42::70, icmp_seq=4 hlim=55 time=46.918 ms
  3. 3 Posted by JGoldman on 17 Sep, 2019 11:04 PM

    JGoldman's Avatar

    I had to disable ipv6 on my ubuntu test bed to get anything to install. This is still very much a problem.

  4. Support Staff 4 Posted by sonalkr132 on 13 Jul, 2020 07:53 AM

    sonalkr132's Avatar


    Sorry about the delay in the resolution here. I personally didn't have access to take any steps here until recently. I have opened a support ticket with Fastly and hopefully, we will make some progress here. Can you please confirm if you are still having this issue?
    If yes, I would like to forward some debugging info about your host/IP to the Fastly team.

    I am begging you to please just delete your AAAA records and have the hostname become ipv4 only

    We are serving a significant number of requests over IPv6. Fastly IPv6 supports seems a bit broken and this affect users in some parts of the world. Hopefully, we will get this resolved this soon.

Discussions are closed to public comments.
If you need help with please start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac