Connection reset by your server

Noël Lucia's Avatar

Noël Lucia

04 Jan, 2019 07:45 PM

Dear staff,

When trying to install a gem remotely using the terminal on Linux, I get the following error :

Unable to download date from - Errno: :ECONNREST: Connection rest by peer - SSl_connect (

What solution is available to circumvent this issue ? What are the reasons for it ?

With kind regards,


  1. Support Staff 1 Posted by kerrizor on 05 Jan, 2019 04:42 PM

    kerrizor's Avatar

    Sorry you're experiencing this issue! A few questions..

    Are you behind a firewall or proxy? Is this still happening? Sometimes we see this kind of thing happen intermittently.

    Have you tried updating to the latest versions of openssl and bundler?

    Have you googled for solutions specific to your platform and OS?

  2. 2 Posted by ncalucia on 07 Jan, 2019 09:41 PM

    ncalucia's Avatar

    I finally solved the issue with the following steps :

    1. I followed the instructions, which I adapted for Debian on :

    The location of the relevant files in Debian systems is explained under

    2. After that, I ran following command in my terminal : sudo update-ca-

    It worked like a charm.

    There was seemingly an issue in how the server had access to the
    certificates on my system.

  3. 3 Posted by Muzammil Hussai... on 12 Jan, 2019 06:10 AM

    Muzammil Hussain's Avatar


    Your solutions also help our web design to get rid of that issue :)

  4. sonalkr132 closed this discussion on 14 Jan, 2019 04:22 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac