RubyGems not showing up even though they are installed

CoolC's Avatar

CoolC

02 Jan, 2019 04:20 PM

I have a RedHay 7 system and I have installed the ruby 2.0.0.648 and rubygem 2.0.14 package and it has also installed a few dependent gems.

My problem is when I run the
gem list command I dont see any of the gems.

If I cd into the /usr/share.gems/gems/ directory I can see all of the files.

My question is…

How can I force the “gems command” to scan the /usr/share/gems/gems directory and update the
*** LOCAL GEMS *** database?

There has to be a way to manually edit the files to tell the gems command that all of the files are really on the system. *

  1. Support Staff 1 Posted by sonalkr132 on 04 Jan, 2019 08:02 AM

    sonalkr132's Avatar

    Hi CoolC,

    Can you please let us know which gem are you trying to install, the command you used and what is output of gem env?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

13 Mar, 2019 02:54 PM
05 Mar, 2019 04:42 PM
28 Feb, 2019 08:51 PM
28 Feb, 2019 05:39 AM
27 Feb, 2019 07:20 AM