Unable to edit newly published gem - Server Error.

kapoorlakshya's Avatar

kapoorlakshya

01 Nov, 2018 08:02 AM

Hi!

I recently pushed my first gem ever. When I click on the "Edit" link, I get a Server Error (screenshot attached). Here is the link that I am using: https://rubygems.org/gems/ffmpeg-screenrecorder/edit

Also, for some reason, the homepage link in the gemspec, pointing to the GitHub repo, is not displayed with the other links. I followed the "Specification Reference" page and set it to:

spec.homepage = 'http://github.com/kapoorlakshya/ffmpeg-screenrecorder'

Am I missing something obvious here?

Thank you!

  1. Support Staff 1 Posted by kerrizor on 01 Nov, 2018 02:42 PM

    kerrizor's Avatar

    The spec looks ok to my quick scan of it, and I'm actually not seeing anything in our logs about an error.. hmm, I'm wondering, did you add or change the homepage link but not publish a new version of the gem? The last version payload I have a record for is for 1.0.0.beta3 and that payload did not include a homepage URL.. perhaps try publishing 1.0.0.beta3.1 and see if it updates?

    In the meanwhile, I'll poke around a bit more and see if I can locate some kind of error log that would've been recorded when you received that server error message; we did have a minor service degradation a few hours ago, but I doubt it is related.

  2. 2 Posted by kapoorlakshya on 01 Nov, 2018 10:11 PM

    kapoorlakshya's Avatar

    Hi kerrizor,

    Thanks for responding!

    The last version payload I have a record for is for 1.0.0.beta3 and that payload did not include a homepage URL

    That's strange. How did you figure this out? The homepage URL is in the gemspec and I can see it when I unpack the gem file for beta3. Actually, it has been there in all releases so far. Here are the steps I have been following:

    gem build ffmpeg-screenrecorder.gemspec
    gem push ffmpeg-screenrecorder-1.0.0.beta3.gem
    

    The server error is happening to me every time I click the "Edit" link. I have attached a GIF recording so you can see the server error (Timestamp should be around 15:10 PDT) in action and my steps to unpack and verify the homepage url in the gemspec.

    EDIT: I used bundle exec rake release with the beta4 release and I get the same results - server error and no homepage URL. Wasn't sure if it made a difference and it apparently does not.

  3. Support Staff 3 Posted by kerrizor on 03 Nov, 2018 01:34 AM

    kerrizor's Avatar

    Found it! It'll take me a few days to get a fix together, just due to scheduling.. I'll update this issue when its working -- thanks!

  4. 4 Posted by kapoorlakshya on 04 Nov, 2018 12:21 AM

    kapoorlakshya's Avatar

    Oh, awesome! Please do share what the issue was - I am curious now.

    Did you figure out a fix for both the Server Error and the homepage issue? Thanks!

  5. Support Staff 5 Posted by kerrizor on 08 Dec, 2018 05:25 PM

    kerrizor's Avatar

    Apologies for the delay in responding - RubyConf got in the way, and then the holiday season kicked into gear here in the US... I'm working on a small patch for the Rubygems.org website, but I wanted to theorize if you'd tried removing the line split (\) on https://github.com/kapoorlakshya/ffmpeg-screenrecorder/blob/master/... - it /shouldn't/ be the culprit, but worth trying?

  6. Support Staff 6 Posted by kerrizor on 08 Dec, 2018 06:03 PM

    kerrizor's Avatar
  7. 7 Posted by kapoorlakshya on 24 Dec, 2018 04:57 AM

    kapoorlakshya's Avatar

    Looks like the Edit feature was removed altogether to fix the bug .

    I'll update the homepage URL to not have the slashes and see if that works. Thanks for responding!

  8. 8 Posted by kapoorlakshya on 24 Dec, 2018 05:50 AM

    kapoorlakshya's Avatar

    I pushed beta7 without the slashes in the description and the Homepage URL still doesn't show up. I compared my gemspec to other gems with a working URL, and I haven't noticed anything obvious.

  9. Support Staff 9 Posted by kerrizor on 25 Dec, 2018 04:16 PM

    kerrizor's Avatar

    The edit functionality has been removed by a different PR (https://github.com/rubygems/rubygems.org/pull/1815) so my patch did not go into effect. The issue with your gem appears to be that we don't update the metadata on "beta" versions. Once you publish a non-beta release (without alphas in the version, if I'm understanding the explanation and code) the data will be updated correctly.

  10. kerrizor closed this discussion on 25 Dec, 2018 04:16 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

13 Mar, 2019 02:54 PM
05 Mar, 2019 04:42 PM
28 Feb, 2019 08:51 PM
28 Feb, 2019 05:39 AM
27 Feb, 2019 07:20 AM