Can't download gems - get Bundler::HTTPError Could not fetch specs from

byofuel's Avatar


18 Sep, 2018 11:54 PM

Console record of the problem is below. Things I tried:

(I had no proxy settings to remove) Get the same error whether going out through my cable model or tethering via my cell phone

[byofuel@MBP-mid15 tonicapi (master)]$ bundle check

Bundler can't satisfy your Gemfile's dependencies.

Install missing gems with 'bundle install'.

[byofuel@MBP-mid15 tonicapi (master)]$ bundle install

The latest bundler is 1.16.0, but you are currently running 1.15.4.

To update, run 'gem install bundle'

The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run 'bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java'.

Fetching source index from

Retrying fetcher due to error (2/4): Bundler::HTTPError Could not fetch specs from

[byofuel@MBP-mid15 tonicapi (master)]$ ping
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=57 time=14.579 ms
64 bytes from icmp_seq=1 ttl=57 time=17.558 ms
64 bytes from icmp_seq=2 ttl=57 time=13.706 ms
--- ping statistics ---
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 13.706/15.281/17.558/1.649 ms

[byofuel@MBP-mid15 tonicapi (master)]$ gem install bundler
ERROR:  Could not find a valid gem 'bundler' (>= 0), here is why:
          Unable to download data from - timed out (

[byofuel@MBP-mid15 tonicapi (master)]$ echo $http_proxy

[byofuel@MBP-mid15 tonicapi (master)]$
  1. byofuel closed this discussion on 19 Sep, 2018 12:20 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac