Unable to download data from https://rubygems.org/ - Received fatal alert: protocol_version

Kalina's Avatar

Kalina

21 Jun, 2018 08:03 AM

I saw that this issue is very often happened by another ruby developer. So the same problem but with gem 'bundler' (= 1.12.5) is by us.
Since 19. Juni 18 come again and again this error message:

ERROR: Could not find a valid gem 'bundler' (= 1.12.5), here is why:
          Unable to download data from https://rubygems.org/ - Received fatal alert: protocol_version (https://rubygems.org/specs.4.8.gz)

Can you please help us?
Best regards

  1. Support Staff 1 Posted by sonalkr132 on 21 Jun, 2018 08:27 AM

    sonalkr132's Avatar

    Hi Kalina,

    Looks like your openssl client doesn't support TLSv1.2. Please consider updating it. We recently removed support for TLSv.1.0 and 1.1 https://blog.rubygems.org/2018/02/24/tls-10-and-11-deprecation-noti...

  2. 2 Posted by david on 21 Apr, 2020 09:14 PM

    david's Avatar

    I am getting this same error using jruby 1.7.22. Trying to install rubyXL. Can you please explain how to update the openssl client.

    macOS 10.14.6

  3. Support Staff 3 Posted by sonalkr132 on 22 Apr, 2020 05:06 AM

    sonalkr132's Avatar

    Hi David,

    I am sorry to hear that you are facing issues. Best I can do for you is provide you google link ;)
    https://www.google.com/search?q=update+the+openssl+client.+macOS+10.14

    Result from medium should be helpful for you.

  4. sonalkr132 closed this discussion on 22 Apr, 2020 05:06 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac