Network timeouts

Ivan's Avatar

Ivan

05 May, 2018 04:22 AM

Hi,

I'm experiencing network timeouts while trying to fetch libraries from rubygems.org.
Running `bundle --verbose`, I noticed some requests were being rate-limited, so I want to check whether my IP address has been blackholed, or whether you can suggest any further debugging steps to find the root cause.

I tried an alternate gem server (gems.ruby-china.org) and found I could fetch libraries from there without issue, but this doesn't seem to be affecting other users.

When I run `bundle --verbose`, I see several successful requests, followed by some rate-limit errors, then more successes:

    HTTP GET https://index.rubygems.org/info/aws-sdk-elasticsearchservice
    ...
    HTTP 200 OK https://index.rubygems.org/info/aws-sdk-marketplacemetering
    ...
    HTTP 429 Too Many Requests https://index.rubygems.org/info/aws-sdk-comprehend
    ...
    HTTP 200 OK https://index.rubygems.org/info/aws-sdk-guardduty
    ...

A few requests to older (`/api/v1`) endpoints follow, and then it just hangs.

    Query Gemcutter Dependency Endpoint API: faraday-middleware,celluloid-gems
    HTTP GET https://index.rubygems.org/api/v1/dependencies?gems=celluloid-gems%2Cfaraday-middleware
    HTTP 200 OK https://index.rubygems.org/api/v1/dependencies?gems=celluloid-gems%2Cfaraday-middleware
    Query List: []

It will sit for quite a while (about 5 minutes, though I haven't timed it) before finally reporting a timeout.

Hoping you can point me in the right direction.
Thank you.

  1. Support Staff 1 Posted by kerrizor on 25 Dec, 2018 03:27 PM

    kerrizor's Avatar

    Thank you for your patience with this tardy response. Is this still an issue that I can help you with?

  2. kerrizor closed this discussion on 25 Dec, 2018 03:27 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

13 Mar, 2019 02:54 PM
05 Mar, 2019 04:42 PM
02 Mar, 2019 10:55 AM
28 Feb, 2019 08:51 PM
28 Feb, 2019 05:39 AM