502 Bad Gateway accessing rubygems.org/yaml

Andrew's Avatar


07 Sep, 2010 03:17 AM

here are the errors:

rails myapp

/usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.8/lib/rails_generator/ options.rb:32:in default_options': undefined methodwrite_inheritable_attribute' for Rails::Generator::Base:Class (NoMethodError)

ok so that means active_support isn't there, but

irb require 'active_support'
=> true it's there folks

gem however has problems

~/Documents$ gem sources -u ERROR: http://rubygems.org/ does not appear to be a repository
ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
bad response Bad Gateway 502 (http://rubygems.org/yaml)

I might add sometimes it works... it's just today.


p.s. I am in Thailand and this is possibly due to a thai firewall problem.

  1. Support Staff 1 Posted by Eric Hodel on 07 Sep, 2010 07:15 AM

    Eric Hodel's Avatar

    An issue with rails needs to be filed in the Rails bug database:


    Can you access rubygems.org from your web browser?

    PS: It looks like your RubyGems is out-of-date.

  2. 2 Posted by Andrew Jones on 07 Sep, 2010 09:04 AM

    Andrew Jones's Avatar

    yeah I fixed it earlier today, Basically my apartment's proxy was keeping
    ruby gems from updating, then I needed to update ruby to 1.9.2 which when I
    did that it replaced the old gems and rails so everything works now.



    On Tue, Sep 7, 2010 at 2:17 PM, drbrain <
    [email blocked]<tender%[email blocked]>
    > wrote:

  3. Eric Hodel closed this discussion on 07 Sep, 2010 05:32 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac