cannot load such file -- bcrypt_ext

gary_1946's Avatar


19 Feb, 2018 10:15 PM

I get this error when I try to run the app. I have tried the gem bcrypt (3.1.11 x86-mingw32) and bcrypt-ruby (3.1.5 x86-mingw32) and get same error.
 Any help here?

  1. Support Staff 1 Posted by kerrizor on 19 Feb, 2018 10:24 PM

    kerrizor's Avatar

    Unfortunately, we do not offer support for individual applications or libraries. Perhaps an issue against the application or library you're having this problem with? I'm not entirely sure which app you're having trouble with..

  2. kerrizor closed this discussion on 19 Feb, 2018 10:24 PM.

  3. gary_1946 re-opened this discussion on 20 Feb, 2018 12:12 PM

  4. 2 Posted by gary_1946 on 20 Feb, 2018 12:12 PM

    gary_1946's Avatar

    Sorry I thought this was like a help forum for problems with gems.


    Thanks for letting me know. I will look someplace else for help.


    I am writing a ruby on rails app that uses defense and when I run the app I get an error “cannot load such file -- bcrypt_ext” In my gemfile I have the gem bcrypt 3.1.11 loading.

    Where would be a good place for asking help on this?

    Thank you for the help


  5. Support Staff 3 Posted by kerrizor on 24 Feb, 2018 04:36 PM

    kerrizor's Avatar

    I would start with Stack Overflow. A quick Google search turned up hundreds of results.

    Best of luck!

  6. kerrizor closed this discussion on 24 Feb, 2018 04:36 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

13 Mar, 2019 02:54 PM
05 Mar, 2019 04:42 PM
28 Feb, 2019 08:51 PM
28 Feb, 2019 05:39 AM
27 Feb, 2019 07:20 AM