Error on chef Opsworks AWS

ynuyasha's Avatar


07 Feb, 2018 12:48 PM

Starting today i have an error with chef 12 on AWS Opsworks

Fetching gem metadata from
Fetching version metadata from
Resolving dependencies...
Installing aws-sigv4 1.0.2
Installing jmespath 1.3.1
Using bundler 1.12.5
Gem::RemoteFetcher::FetchError: Errno::ECONNRESET: Connection reset by peer - SSL_connect (
An error occurred while installing aws-sdk-core (2.10.127), and Bundler cannot
Make sure that `gem install aws-sdk-core -v '2.10.127'` succeeds before
---- End output of bundle install ----
Ran bundle install returned 5
[2018-02-07T09:50:55+00:00] FATAL: Chef::Exceptions::ChildConvergeError: Chef run process exited unsuccessfully (exit code 1)

Anyone as same problem?

  1. Support Staff 1 Posted by kerrizor on 07 Feb, 2018 05:08 PM

    kerrizor's Avatar

    Are you behind a firewall or proxy? Sometimes we see this kind of thing happen intermittently.

    Have you tried updating to the latest versions of openssl and bundler?

  2. 2 Posted by Tanuj on 08 Feb, 2018 03:19 PM

    Tanuj's Avatar

    We are seeing the same issue today from AWS eu-west-1 region.

    [0;32m amazon-ebs: TASK [ruby : Get Rubygems] *****************************************************  amazon-ebs: fatal: []: FAILED! => {"changed": false, "dest": "/tmp/", "msg": "Request failed: ", "state": "absent", "url": ""}

  3. 3 Posted by ynuyasha on 08 Feb, 2018 03:29 PM

    ynuyasha's Avatar

    I'm on eu-west-1 region too.

  4. 4 Posted by Tanuj on 08 Feb, 2018 03:55 PM

    Tanuj's Avatar

    The issue seems to be with the SSL connection. It connects intermittently.

    root@ip-10-X-X-X:/home/ubuntu/rubygems-2.7.4# wget
    --2018-02-08 15:24:37-- Resolving (,,, ...
    Connecting to (||:443... connected.
    Unable to establish SSL connection.

    root@ip-X-X-X-X:/home/ubuntu/rubygems-2.7.4# wget
    --2018-02-08 15:24:47-- Resolving (,,, ...
    Connecting to (||:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1138574 (1.1M) [application/zip]
    Saving to: ‘’

  5. 5 Posted by Tanuj on 08 Feb, 2018 07:43 PM

    Tanuj's Avatar

    Fastly which host rubygems and even pypi were throttling our AWS IP's from AWS Ireland region. I modified the public ip and its fixed it for now. The same should help to you ynuyasha as well.

  6. Support Staff 6 Posted by kerrizor on 08 Feb, 2018 08:10 PM

    kerrizor's Avatar

    Glad it could get sorted!

  7. kerrizor closed this discussion on 08 Feb, 2018 08:10 PM.

  8. ynuyasha re-opened this discussion on 09 Feb, 2018 01:36 PM

  9. 7 Posted by ynuyasha on 09 Feb, 2018 01:36 PM

    ynuyasha's Avatar

    i can't change external ip because is our NAT gateway that we use for other reason, so we present to Internet always with the same ip's

  10. 8 Posted by Tanuj on 09 Feb, 2018 05:57 PM

    Tanuj's Avatar

    Fastly has recognised the issue.

  11. Support Staff 9 Posted by kerrizor on 10 Feb, 2018 10:49 PM

    kerrizor's Avatar

    At this time Fastly believes the issue resolved. More information can be found here:

  12. kerrizor closed this discussion on 10 Feb, 2018 10:49 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac