Can't add source

Frank Jensen's Avatar

Frank Jensen

06 May, 2010 10:23 PM

Hello Rubygems,

I'm still a rookie in the RoR and Gem universe but I'm getting to the point where i need to look at deployment. I was planning on using Capistrano for this. It turns out that I can't install it because my gem sources aren't updated. I had as my only source and i get an error regarding the source. When I try to add as a source I get the following error:

# gem source -a

Error fetching
    SocketError: getaddrinfo: Name or service not known (

I can add fint, but it seems they stopped hosting gems. Do you have any suggestions to fix this problem?

Frank Jensen

  1. Support Staff 1 Posted by Eric Hodel on 06 May, 2010 11:47 PM

    Eric Hodel's Avatar

    Seems like your DNS is broken:

    $ host has address mail is handled by 10 mail is handled by 20

  2. 2 Posted by Frank Jensen on 07 May, 2010 05:55 AM

    Frank Jensen's Avatar

    I get the same result, i can ping and lookup the URL just fine, i just can't add it to my gem source list :-(

  3. 3 Posted by Frank Jensen on 07 May, 2010 07:55 AM

    Frank Jensen's Avatar

    I just accurately tried again, and now i successfully added rubygems as a source. May just have been a network problem from my server. Im not sure. Anyways, thanks for your support in this matter :-)

  4. Support Staff 4 Posted by Nick Quaranto on 12 May, 2010 04:07 AM

    Nick Quaranto's Avatar

    Going to consider this resolved then! If there's any other problems with this feel free to reopen it.

  5. Nick Quaranto closed this discussion on 12 May, 2010 04:07 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac