gem cleanup + uninstall dependency lists

James Tucker's Avatar

James Tucker

01 Apr, 2010 11:42 AM

Current gem cleanup and uninstall present a dependents list that is confusing, in the below example, given other gems installed, it could and maybe should only display rdoc_osx_dictionary, furthermore several of the other dependents are only development dependencies, which may want to be indicated also.

raggi@mbk: ~ * sudo gem cleanup rdoc
Cleaning up installed gems...
Attempting to uninstall rdoc-2.4.3

You have requested to uninstall the gem:
    rdoc-2.4.3
subload-1.0.3 depends on [rdoc (>= 2.4.3)]
rdoc_osx_dictionary-1.3.0 depends on [rdoc (~> 2.4.3)]
rdoc_osx_dictionary-1.3.1 depends on [rdoc (~> 2.4.3)]
async_sinatra-0.1.5 depends on [rdoc (>= 2.4.1)]
rhodes-1.4.2 depends on [rdoc (>= 2.4.3)]
  1. Support Staff 1 Posted by Nick Quaranto on 17 Jul, 2010 08:25 PM

    Nick Quaranto's Avatar

    Gross. Is this still happening?

  2. Support Staff 2 Posted by James Tucker on 18 Jul, 2010 12:20 PM

    James Tucker's Avatar

    yes

  3. Support Staff 3 Posted by John Barnette on 17 Nov, 2010 07:45 AM

    John Barnette's Avatar

    This is covered by a ticket in the tracker now, I think. Drop info there if it's not complete:

    http://rubyforge.org/tracker/index.php?func=detail&aid=28713&am...

  4. John Barnette closed this discussion on 17 Nov, 2010 07:45 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac