symbol glossary question

Gabriel Ferreira's Avatar

Gabriel Ferreira

14 Nov, 2013 01:53 PM

Hi. I was downloading some gems, and then something came up and i have a question now.

The gem i was downloading is: http://rubygems.org/gems/mail/versions/2.5.3

According to the webpage, we can see this:

Runtime Dependencies
    i18n >= 0.4.0
    mime-types ~> 1.16
    treetop ~> 1.4.8

What means ~> ?
By the way, it would be nice if the rubygems.org have some type of glossary, for this kind purposes.

  1. Support Staff 2 Posted by Luis Lavena on 14 Nov, 2013 04:06 PM

    Luis Lavena's Avatar

    Hello Gabriel,

    Please see RubyGems guides that describe versioning patterns:

    http://guides.rubygems.org/patterns/#declaring_dependencies

    Look for "pessimistic versioning"

  2. 3 Posted by Gabriel Ferreira on 14 Nov, 2013 05:01 PM

    Gabriel Ferreira's Avatar

    Cool. Thanks for your help :)

    Best regards,
    Gabriel.

  3. Nick Quaranto closed this discussion on 06 Mar, 2014 03:10 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac