mysql2 cannot connect to localhost server

Larry's Avatar

Larry

22 Mar, 2012 09:36 AM

I tried with -h 12.0.0.1 and now when I do rake db:migrate --" rake abort unknown mysql server host '-h 12.0.0.1 (0)' ". I tested with mysql -u root and get connected without any trouble. Here is what I am using Ruby 1.9.3 rails 3.2.2. Mysql2 is 0.3.11 and download the libmsql.dll as instructed Mysql is 5.1 I am running this on a Windows Vista and also tried on a Win7. I tried every ways on the web that I can find.

  1. Support Staff 2 Posted by Eric Hodel on 22 Mar, 2012 08:32 PM

    Eric Hodel's Avatar

    This help forum is for help with rubygems itself, not for help with gems you have installed.

    Please try contacting the authors of the mysql2 gem for support.

  2. Eric Hodel closed this discussion on 22 Mar, 2012 08:32 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac