cannot install any gem

reiswindy's Avatar

reiswindy

01 Apr, 2012 06:15 PM

For some reason everytime I've tried using the gem install command (even with sudo) in Ubuntu 11.10, it returns a message about the gem not being found in any repository. gem sources show http://rubygems.org listed, but it won't connect.

ERROR: Could not find a valid gem 'rake' (>= 0) in any repository
ERROR: While executing gem ... (Gem::RemoteFetcher::FetchError)
Errno::ENETUNREACH: Network is unreachable - connect(2) (http://rubygems.org/latest_specs.4.8.gz)

I'm using my own laptop and I'm not using any type of firewall. Ping showed the server was reachable, but it won't let me install any gems (tried with rubygame, rake, ffi, rudy-sdl-ffi, nice-ffi) without success. if anyone could solve my problem i would be very grateful

  1. Support Staff 2 Posted by Nick Quaranto on 04 Aug, 2012 06:32 PM

    Nick Quaranto's Avatar

    Sorry, this comment was buried in our spam inbox.

    Is this still happening?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Aug, 2014 06:23 PM
28 Aug, 2014 07:18 PM
27 Aug, 2014 12:03 PM
26 Aug, 2014 07:09 PM
26 Aug, 2014 07:07 PM