rubygems 1.3.7

elizabeth.apodaca's Avatar

elizabeth.apodaca

22 Mar, 2012 04:16 PM

I have Ubuntu 8.04 installed on a virtual machine.
Ruby 1.9.1 p378 is installed
I need to have rubygems 1.3.7 installed to reproduce a production environment using rails.
I have tried downloading rubygems 1.3.7 both through update and the manual download/extract/buIld method.
When I update the system - I end up with error messages:

:~/rubygems-1.3.7$ gem list
/usr/local/lib/ruby/site_ruby/1.9.1/rubygems/config_file.rb:71:in `rescue in rescue in <class:ConfigFile>': uninitialized constant Gem::ConfigFile::RbConfig (NameError)
    from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/config_file.rb:53:in `rescue in <class:ConfigFile>'
    from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/config_file.rb:49:in `<class:ConfigFile>'
    from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/config_file.rb:28:in `<top (required)>'
    from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/gem_runner.rb:9:in `require'
    from /usr/local/lib/ruby/site_ruby/1.9.1/rubygems/gem_runner.rb:9:in `<top (required)>'
    from /usr/local/bin/gem:9:in `require'
    from /usr/local/bin/gem:9:in `<main>'

When I look in which gem: it displays:

#!/usr/local/bin/ruby
#--
# Copyright 2006 by Chad Fowler, Rich Kilmer, Jim Weirich and others.
# All rights reserved.
# See LICENSE.txt for permissions.
#++

require 'rubygems'
require 'rubygems/gem_runner'
require 'rubygems/exceptions'

required_version = Gem::Requirement.new ">= 1.8.7"

unless required_version.satisfied_by? Gem.ruby_version then
  abort "Expected Ruby Version #{required_version}, is #{Gem.ruby_version}"
end

args = ARGV.clone

begin
  Gem::GemRunner.new.run args
rescue Gem::SystemExitException => e
  exit e.exit_code
end

There is a folder called 1.8 - under this folder is 1.3.6

Can anyone help with installing 1.3.7 properly and getting it running?

  1. Support Staff 1 Posted by Eric Hodel on 22 Mar, 2012 08:37 PM

    Eric Hodel's Avatar

    What is the result of ruby -v -rrbconfig -e 'p RbConfig' and gem env?

  2. 2 Posted by elizabeth.apoda... on 25 Mar, 2012 05:15 PM

    elizabeth.apodaca's Avatar

    ruby -v: ruby 1.9.1-p378 (2010-01-10 revision 26273) [86x_64-linux]

    -rrbconfig -e: -rrbconfig Command not found

    p RbConfig: command not found

    -rrbconfig -e 'p RbConfig: This produces a promt as ia a program is running but no output. I used Ctrl C to exit it.

    gem env:
    RubyGems Environment:
     -RUBYGEMS VERSION : 1.3.7
     -RUBY VERSION: 1.9.1 (2010-01-10 patch level 378) [x86_64-linux]
     -INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.9.1
     -RUBY EXECUTABLE: /usr/local/bin/ruby
     -EXECUTABLE DIRECTORY: /usr/local/bin
     -RUBYGEMS PLATFORMS: 
      -rubygems
      -x86_64-linux
     -GEM PATHS: 
      -/usr/local/lib/rubygems/1.9.1
      -/home/polytest/.gem/ruby/1.9.1
     -GEM CONFIGURATION:
      -:update_sources => true
      -:verbose => true
      -:benchmark => false
      -:backtrace => false
      -:bulk_threshhold =>1000
     -REMOTE SOURCES:
      - http://rubygems.org
    
  3. 3 Posted by elizabeth.apoda... on 25 Mar, 2012 05:18 PM

    elizabeth.apodaca's Avatar

    Note that this is now on Ubuntu 10.04 64 bit

  4. Support Staff 4 Posted by Nick Quaranto on 04 Aug, 2012 05:47 PM

    Nick Quaranto's Avatar

    Catching up on issues....

    Is this still a problem?

  5. 5 Posted by elizabeth.apoda... on 05 Aug, 2012 04:32 PM

    elizabeth.apodaca's Avatar

    No. I solved this a long time ago.

  6. Nick Quaranto closed this discussion on 14 Aug, 2012 01:49 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM