Trying to install RubyGems

avigdorfin's Avatar

avigdorfin

25 Jan, 2012 03:31 PM

I downloaded rubygems-1.8.15 from RubyForge and tried to install as directed and got the error below.
Running on CentOS release 5.7, I checked the ruby version that I find to be "ruby 1.8.5 (2006-08-25) [i386-linux]", so I downloaded rubygems-1.8.5 and tried again, but got the same error(s).
Can I get some help how to resolve the issue?

Many Thanks.

-~/rubygems-1.8.15-519# ruby setup.rb ./lib/rubygems.rb:332: warning: parenthesize argument(s) for future version ./lib/rubygems.rb:514: warning: parenthesize argument(s) for future version ./lib/rubygems.rb:30:in `require': ./lib/rubygems/deprecate.rb:54: syntax error (SyntaxError)

    define_method name do |*args, &block| # TODO: really works on 1.8.7?
                                 ^

./lib/rubygems/deprecate.rb:55: syntax error ./lib/rubygems/deprecate.rb:64: syntax error ./lib/rubygems/deprecate.rb:69: syntax error from ./lib/rubygems.rb:30

    from setup.rb:27:in `require'
    from setup.rb:27
  1. Support Staff 1 Posted by Luis Lavena on 25 Jan, 2012 06:06 PM

    Luis Lavena's Avatar

    Latest version of RubyGems that support 1.8.6 is 1.3.7

    Anything newer requires Ruby 1.8.7 or greater.

  2. Luis Lavena closed this discussion on 25 Jan, 2012 06:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac