Getting 500 Error When Attempting to Push Gem

Jeremy Evans's Avatar

Jeremy Evans

01 Sep, 2013 03:52 PM

I'm trying to push a new release of Sequel and getting a 500 error:

$ gem push -V sequel-4.2.0.gem
HEAD http://gems.rubyforge.org/latest_specs.4.8.gz
301 Moved Permanently
HEAD https://rubygems.org/latest_specs.4.8.gz
302 Moved Temporarily
HEAD https://s3.amazonaws.com/production.s3.rubygems.org/latest_specs.4.8.gz
304 Not Modified
Pushing gem to https://rubygems.org...
POST https://rubygems.org/api/v1/gems
500 Internal Server Error
<html>
<head><title>500 Internal Server Error</title></head>
<body bgcolor="white">
<center><h1>500 Internal Server Error</h1></center>
<hr><center>nginx</center>
</body>
</html>

  1. 1 Posted by Jeremy Evans on 01 Sep, 2013 04:12 PM

    Jeremy Evans's Avatar

    The only thing that changed in the gemspec from the last release is the addition of spec.license = 'MIT'

  2. 2 Posted by ru on 01 Sep, 2013 08:02 PM

    ru's Avatar

    +1, seeing the same behavior. Tried form a few different networks for good measure with the same result.

  3. 3 Posted by Sik on 01 Sep, 2013 08:40 PM

    Sik's Avatar

    Still no answers?
    I'm dealind with the same issue.

  4. 4 Posted by Did on 01 Sep, 2013 09:02 PM

    Did's Avatar

    I'm sorry, same behavior when pushing new gems for LocomotiveCMS. Thanks!

  5. Support Staff 5 Posted by Nick Quaranto on 02 Sep, 2013 04:41 AM

    Nick Quaranto's Avatar

    Looks like there's some problems with our new load balancer setup. We're looking into this right now, and hopefully will be fixed soon. Sorry everyone!

  6. 6 Posted by Didier Lafforgu... on 02 Sep, 2013 09:47 AM

    Didier Lafforgue's Avatar

    It works now! Thanks Nick.

    -- 
    Creator of LocomotiveCMS

  7. 7 Posted by sikian on 02 Sep, 2013 01:38 PM

    sikian's Avatar

    It works for me as well, thanks! :D

  8. 8 Posted by moserke on 03 Sep, 2013 10:51 PM

    moserke's Avatar

    I'm still having this issue:

    HEAD http://rubygems.org/latest_specs.4.8.gz
    302 Found
    HEAD http://production.s3.rubygems.org/latest_specs.4.8.gz
    304 Not Modified
    Pushing gem to https://rubygems.org...
    POST https://rubygems.org/api/v1/gems
    500 Internal Server Error
    <html>
    <head><title>500 Internal Server Error</title></head>
    <body bgcolor="white">
    <center><h1>500 Internal Server Error</h1></center>
    <hr><center>nginx</center>
    </body>
    </html>

  9. 9 Posted by tombenner on 05 Sep, 2013 10:49 PM

    tombenner's Avatar

    I'm having this issue as well; I've been getting the following 500 error consistently for the last hour or so:

    GET http://rubygems.org/latest_specs.4.8.gz
    302 Moved Temporarily
    GET http://production.s3.rubygems.org/latest_specs.4.8.gz
    304 Not Modified
    Pushing gem to https://rubygems.org...
    POST https://rubygems.org/api/v1/gems
    500 Internal Server Error
    <html>
    <head><title>500 Internal Server Error</title></head>
    <body bgcolor="white">
    <center><h1>500 Internal Server Error</h1></center>
    <hr><center>nginx</center>
    </body>
    </html>

    A resolution would be great, as this is blocking development. Thanks!

  10. Support Staff 10 Posted by Nick Quaranto on 11 Nov, 2013 08:33 PM

    Nick Quaranto's Avatar

    Is this still happening?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac