can't push new version of gem

kookster's Avatar

kookster

29 Aug, 2013 09:26 PM

I'm trying to push a new version of the amara gem I am working on.
Worked a couple weeks ago, now it gives me 500 errors on submit to rubygems.
Here is output using gem push with verbose and debug on -

    [17:19:38][andrew][~/dev/projects/amara]> gem push -V --debug pkg/amara-0.0.4.gem
    Exception `Errno::EEXIST' at /Users/andrew/.rbenv/versions/1.9.3-p392/lib/ruby/1.9.1/fileutils.rb:247 - File exists - /Users/andrew/.gem/specs/rubygems.org%443
    HEAD https://rubygems.org/latest_specs.4.8.gz
    Exception `OpenSSL::SSL::SSLError' at /Users/andrew/.rbenv/versions/1.9.3-p392/lib/ruby/1.9.1/openssl/buffering.rb:174 - read would block
    302 Moved Temporarily
    HEAD https://s3.amazonaws.com/production.s3.rubygems.org/latest_specs.4.8.gz
    Exception `OpenSSL::SSL::SSLError' at /Users/andrew/.rbenv/versions/1.9.3-p392/lib/ruby/1.9.1/openssl/buffering.rb:174 - read would block
    304 Not Modified
    Pushing gem to https://rubygems.org...
    POST https://rubygems.org/api/v1/gems
    Exception `OpenSSL::SSL::SSLError' at /Users/andrew/.rbenv/versions/1.9.3-p392/lib/ruby/1.9.1/openssl/buffering.rb:174 - read would block
    500 Internal Server Error
    <html>
    <head><title>500 Internal Server Error</title></head>
    <body bgcolor="white">
    <center><h1>500 Internal Server Error</h1></center>
    <hr><center>nginx</center>
    </body>
    </html>

  1. Support Staff 1 Posted by Evan Phoenix on 29 Aug, 2013 10:20 PM

    Evan Phoenix's Avatar

    This should be cleared up now. We had an issue with a load balancer.

  2. Evan Phoenix closed this discussion on 29 Aug, 2013 10:20 PM.

  3. kookster re-opened this discussion on 30 Aug, 2013 04:37 PM

  4. 2 Posted by kookster on 30 Aug, 2013 04:37 PM

    kookster's Avatar

    all good now, thanks!

  5. 3 Posted by ru on 01 Sep, 2013 07:58 PM

    ru's Avatar

    I am seeing this error message this morning:

    Exception `OpenSSL::SSL::SSLError' at /usr/lib/ruby/1.9.1/openssl/buffering.rb:174 - read would block

    Worked like a charm yesterday. Maybe related to the previous load balancer issue? I tried this on Ubuntu and Mac with the same result.

  6. 4 Posted by lifepillar on 01 Sep, 2013 08:06 PM

    's Avatar

    Same here:

    Exception `Errno::EEXIST' at /Users/me/.rbenv/versions/2.0.0-p247/lib/ruby/2.0.0/fileutils.rb:245 - File exists - /Users/me/.gem/specs/rubygems.org%443
    HEAD https://rubygems.org/latest_specs.4.8.gz
    Exception `OpenSSL::SSL::SSLError' at /Users/me/.rbenv/versions/2.0.0-p247/lib/ruby/2.0.0/openssl/buffering.rb:174 - read would block
    302 Moved Temporarily
    HEAD https://s3.amazonaws.com/production.s3.rubygems.org/latest_specs.4.8.gz
    Exception `OpenSSL::SSL::SSLError' at /Users/me/.rbenv/versions/2.0.0-p247/lib/ruby/2.0.0/openssl/buffering.rb:174 - read would block
    200 OK
    GET https://rubygems.org/latest_specs.4.8.gz
    Exception `OpenSSL::SSL::SSLError' at /Users/me/.rbenv/versions/2.0.0-p247/lib/ruby/2.0.0/openssl/buffering.rb:174 - read would block
    302 Moved Temporarily
    GET https://s3.amazonaws.com/production.s3.rubygems.org/latest_specs.4.8.gz
    Exception `OpenSSL::SSL::SSLError' at /Users/me/.rbenv/versions/2.0.0-p247/lib/ruby/2.0.0/openssl/buffering.rb:174 - read would block
    [lots of copies of the message above]
    200 OK
    Exception `NoMethodError' at /Users/me/.rbenv/versions/2.0.0-p247/lib/ruby/2.0.0/rubygems/package.rb:421 - undefined method `readpartial' for #<Gem::Package::TarReader::Entry:0x007ff69348b2c8>
    [lots of copies of the message above]
    Pushing gem to https://rubygems.org...
    POST https://rubygems.org/api/v1/gems
    500 Internal Server Error
    <html>
    <head><title>500 Internal Server Error</title></head>
    <body bgcolor="white">
    <center><h1>500 Internal Server Error</h1></center>
    <hr><center>nginx</center>
    </body>
    </html>

  7. 5 Posted by nathan on 01 Sep, 2013 09:42 PM

    nathan's Avatar

    same:

    Pushing gem to https://rubygems.org...
    <html>
    <head><title>500 Internal Server Error</title></head>
    <body bgcolor="white">
    <center><h1>500 Internal Server Error</h1></center>
    <hr><center>nginx</center>
    </body>
    </html>

  8. 6 Posted by Peter Wagenet on 01 Sep, 2013 10:24 PM

    Peter Wagenet's Avatar

    I'm getting the same issue as Nathan.

  9. 7 Posted by saranyan on 02 Sep, 2013 04:07 AM

    saranyan's Avatar

    +1. Same issue here too. Was working fine yesterday.

  10. 8 Posted by ru on 02 Sep, 2013 04:37 AM

    ru's Avatar

    Appears to be working now. Woot!

  11. Support Staff 9 Posted by Nick Quaranto on 02 Sep, 2013 04:41 AM

    Nick Quaranto's Avatar

    Looks like there's some problems with our new load balancer setup. We're looking into this right now, and hopefully will be fixed soon. Sorry everyone!

  12. 10 Posted by Saranyan Vigrah... on 02 Sep, 2013 04:42 AM

    Saranyan Vigraham's Avatar

    --
    Saranyan Vigraham
    Sent with Sparrow (http://www.sparrowmailapp.com/?sig)

  13. 11 Posted by nathan on 02 Sep, 2013 04:46 AM

    nathan's Avatar

    working for me now, thx all

  14. Support Staff 12 Posted by Nick Quaranto on 02 Sep, 2013 04:49 AM

    Nick Quaranto's Avatar

    Should be fixed now. Let us know if you're having trouble still!

  15. Nick Quaranto closed this discussion on 02 Sep, 2013 04:49 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 04:34 PM
30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM