Yet another "too many connection resets"

Goran Topic's Avatar

Goran Topic

30 Jul, 2013 03:35 AM

I think it might be a problem with the mirror I'm being redirected to.

$ gem install jekyll --verbose
HEAD http://rubygems.org/latest_specs.4.8.gz
302 Moved Temporarily
HEAD http://production.s3.rubygems.org/latest_specs.4.8.gz
304 Not Modified
GET http://rubygems.org/quick/Marshal.4.8/jekyll-1.1.2.gemspec.rz
302 Moved Temporarily
GET http://tokyo-m.rubygems.org/quick/Marshal.4.8/jekyll-1.1.2.gemspec.rz
connection reset after 1 requests, retrying
GET http://tokyo-m.rubygems.org/quick/Marshal.4.8/jekyll-1.1.2.gemspec.rz
connection reset after 1 requests, retrying
ERROR:  Could not find a valid gem 'jekyll' (>= 0), here is why:
          Unable to download data from http://rubygems.org/ - too many connection resets (http://tokyo-m.rubygems.org/quick/Marshal.4.8/jekyll-1.1.2.gemspec.rz)
HEAD http://rubygems.org/prerelease_specs.4.8.gz
302 Moved Temporarily
HEAD http://production.s3.rubygems.org/prerelease_specs.4.8.gz
304 Not Modified
HEAD http://rubygems.org/specs.4.8.gz
302 Moved Temporarily
HEAD http://production.s3.rubygems.org/specs.4.8.gz
304 Not Modified
ERROR:  Possible alternatives: jekyll

Trying to manually download from rubygems.org:

$ wget http://rubygems.org/downloads/jekyll-1.1.2.gem
--2013-07-30 12:30:42--  http://rubygems.org/downloads/jekyll-1.1.2.gem
Resolving rubygems.org... 54.245.255.174
Connecting to rubygems.org|54.245.255.174|:80... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://rubygems.org/gems/jekyll-1.1.2.gem [following]
--2013-07-30 12:30:42--  http://rubygems.org/gems/jekyll-1.1.2.gem
Reusing existing connection to rubygems.org:80.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://tokyo-m.rubygems.org/gems/jekyll-1.1.2.gem [following]
--2013-07-30 12:30:42--  http://tokyo-m.rubygems.org/gems/jekyll-1.1.2.gem
Resolving tokyo-m.rubygems.org... 106.187.99.185
Connecting to tokyo-m.rubygems.org|106.187.99.185|:80... connected.
HTTP request sent, awaiting response... No data received.
Retrying.

--2013-07-30 12:30:45--  (try: 2)  http://tokyo-m.rubygems.org/gems/jekyll-1.1.2.gem
Connecting to tokyo-m.rubygems.org|106.187.99.185|:80... connected.
HTTP request sent, awaiting response... No data received.
Retrying.

etc. Same thing happens with the top page (http://tokyo-m.rubygems.org/).

Can I use another mirror? Is there a better place to report a malfunctioning mirror? Or is there something obvious that I am missing?

Thank you.

  1. Support Staff 1 Posted by Nick Quaranto on 06 Aug, 2013 11:48 PM

    Nick Quaranto's Avatar

    Is this still happening?

  2. 2 Posted by kabadesu on 26 Aug, 2013 09:31 AM

    kabadesu's Avatar

    This is still happening for me.

  3. Support Staff 3 Posted by Nick Quaranto on 11 Nov, 2013 08:30 PM

    Nick Quaranto's Avatar

    We recently changed CDNs to Fastly. Is this still a problem?

  4. 4 Posted by Andrew Solomon on 05 Dec, 2013 05:58 AM

    Andrew Solomon's Avatar

    I'm having this same issue. It's still happening for me too.

  5. 5 Posted by Dmitriy Pashin on 23 Jun, 2018 05:03 AM

    Dmitriy Pashin's Avatar

    got same problem yesterday.
    fatal: [some_vm]: FAILED! => {"changed": false, "cmd": "/usr/bin/gem install --version 0.6.11 --no-user-install --no-document i18n", "msg": "ERROR: Could not find a valid gem 'i18n' (= 0.6.11), here is why:\n Unable to download data from https://rubygems.org/ - too many connection resets (https://api.rubygems.org/specs.4.8.gz)\nERROR: Possible alternatives: i18n", "rc": 2, "stderr": "ERROR: Could not find a valid gem 'i18n' (= 0.6.11), here is why:\n Unable to download data from https://rubygems.org/ - too many connection resets (https://api.rubygems.org/specs.4.8.gz)\nERROR: Possible alternatives: i18n\n", "stderr_lines": ["ERROR: Could not find a valid gem 'i18n' (= 0.6.11), here is why:", " Unable to download data from https://rubygems.org/ - too many connection resets (https://api.rubygems.org/specs.4.8.gz)", "ERROR: Possible alternatives: i18n"], "stdout": "", "stdout_lines": []}

  6. 6 Posted by Fabio Neves on 25 Jun, 2018 02:55 PM

    Fabio Neves's Avatar

    Having the same problems now:

    The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
    Fetching gem metadata from http://rubygems.org/...
    Retrying dependency api due to error (2/4): Bundler::HTTPError Network error while fetching http://index.rubygems.org/api/v1/dependencies?gems=active_model_serializers%2Cautoprefixer-rails%2Cawesome_print%2Caws-sdk%2Caxlsx%2Caxlsx_rails%2Cbootstrap-daterangepicker-rails%2Cbootstrap-sass%2Cbraintree%2Cbrowser%2Cconnection_pool%2Ccountry_select%2Cdalli%2Cdevise%2Cdevise_invitable%2Cfast_jsonapi%2Cfog%2Cfont-awesome-sass%2Cgeocoder%2Cgon%2Cjbuilder%2Cjquery-rails%2Cjquery-ui-rails%2Ckaminari%2Cmailgun-ruby%2Cmodernizr-rails%2Cmomentjs-rails%2Cmoney-rails%2Cnexmo%2Cnokogiri%2Coauth2%2Cpaperclip%2Cpg%2Cpg_search%2Cpremailer-rails%2Cpretty_backtrace%2Cpuma%2Crails%2Crails-i18n%2Credis%2Crequest_store%2Crollbar%2Crubyzip%2Csass-rails%2Cscenic%2Cselect2-rails%2Csidekiq%2Csimple_form%2Cstripe%2Ctrix (too many connection resets (due to Connection reset by peer - Errno::ECONNRESET) after 1 requests on 2204561780, last used 1.056084 seconds ago)
    Retrying dependency api due to error (3/4): Bundler::HTTPError Network error while fetching http://index.rubygems.org/api/v1/dependencies?gems=active_model_serializers%2Cautoprefixer-rails%2Cawesome_print%2Caws-sdk%2Caxlsx%2Caxlsx_rails%2Cbootstrap-daterangepicker-rails%2Cbootstrap-sass%2Cbraintree%2Cbrowser%2Cconnection_pool%2Ccountry_select%2Cdalli%2Cdevise%2Cdevise_invitable%2Cfast_jsonapi%2Cfog%2Cfont-awesome-sass%2Cgeocoder%2Cgon%2Cjbuilder%2Cjquery-rails%2Cjquery-ui-rails%2Ckaminari%2Cmailgun-ruby%2Cmodernizr-rails%2Cmomentjs-rails%2Cmoney-rails%2Cnexmo%2Cnokogiri%2Coauth2%2Cpaperclip%2Cpg%2Cpg_search%2Cpremailer-rails%2Cpretty_backtrace%2Cpuma%2Crails%2Crails-i18n%2Credis%2Crequest_store%2Crollbar%2Crubyzip%2Csass-rails%2Cscenic%2Cselect2-rails%2Csidekiq%2Csimple_form%2Cstripe%2Ctrix (too many connection resets (due to Connection reset by peer - Errno::ECONNRESET) after 0 requests on 2204561780, last used 0.27884 seconds ago)
    Retrying dependency api due to error (4/4): Bundler::HTTPError Network error while fetching http://index.rubygems.org/api/v1/dependencies?gems=active_model_serializers%2Cautoprefixer-rails%2Cawesome_print%2Caws-sdk%2Caxlsx%2Caxlsx_rails%2Cbootstrap-daterangepicker-rails%2Cbootstrap-sass%2Cbraintree%2Cbrowser%2Cconnection_pool%2Ccountry_select%2Cdalli%2Cdevise%2Cdevise_invitable%2Cfast_jsonapi%2Cfog%2Cfont-awesome-sass%2Cgeocoder%2Cgon%2Cjbuilder%2Cjquery-rails%2Cjquery-ui-rails%2Ckaminari%2Cmailgun-ruby%2Cmodernizr-rails%2Cmomentjs-rails%2Cmoney-rails%2Cnexmo%2Cnokogiri%2Coauth2%2Cpaperclip%2Cpg%2Cpg_search%2Cpremailer-rails%2Cpretty_backtrace%2Cpuma%2Crails%2Crails-i18n%2Credis%2Crequest_store%2Crollbar%2Crubyzip%2Csass-rails%2Cscenic%2Cselect2-rails%2Csidekiq%2Csimple_form%2Cstripe%2Ctrix (too many connection resets (due to Connection reset by peer - Errno::ECONNRESET) after 0 requests on 2204561780, last used 0.277774 seconds ago)

    Retrying fetcher due to error (2/4): Bundler::HTTPError Could not fetch specs from http://rubygems.org/

  7. 7 Posted by hadi on 06 Nov, 2018 02:00 PM

    hadi 's Avatar

    i have this issue

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac