Gem push pushing to incorrect gem name

Robert White's Avatar

Robert White

20 Jul, 2013 06:51 PM

Hi

I tried originally creating a SO question for this, but have yet to receive a response.

I originally created a gem called Sly. After pushing an initial version (0.0.1), I switched to the name sly (lowercase). Each subsequent push worked fine until my latest one (0.0.12).

On pushing, the gem was instead pushed to Sly (uppercase), even though the name is still sly (lowercase) and the gems generated by rake gem and gem build are still sly-0.0.12.gem etc.

Further details including my gemspec for the fie can be found on my original SO question here:

http://stackoverflow.com/questions/17743715/gem-push-pushing-to-wrong-gem-on-rubygems

Thanks for any help you can provide.

  1. Support Staff 2 Posted by Nick Quaranto on 07 Aug, 2013 12:22 AM

    Nick Quaranto's Avatar

    What's does gem spec on the built gem for 0.0.12 say? Seems like something is off here.

  2. 3 Posted by Robert White on 07 Aug, 2013 08:19 AM

    Robert White's Avatar

    I've attached the output when running `gem spec`.

  3. Support Staff 4 Posted by Nick Quaranto on 11 Nov, 2013 08:19 PM

    Nick Quaranto's Avatar

    Strange. Gemspec seems normal. Has this still been happening?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Aug, 2014 06:23 PM
28 Aug, 2014 07:18 PM
27 Aug, 2014 12:03 PM
26 Aug, 2014 07:09 PM
26 Aug, 2014 07:07 PM