I can not install rails-4.0.0.gem,somebody help me ,help me~

Com's Avatar


07 Jul, 2013 01:36 PM

I have try a lot of time ,but can't make it~

[root@comande redmine]# gem install -l rails-4.0.0.gem
ERROR: While executing gem ... (Gem::DependencyError)
    Unable to resolve dependencies: activemodel requires builder (~> 3.1.0); actionpack requires builder (~> 3.1.0)

I can't download builder-3.1.0.gem, but I have builder-3.2.2

Help me ~~~

  1. 1 Posted by Luis Lavena on 07 Jul, 2013 01:43 PM

    Luis Lavena's Avatar


    Seems you have downloaded rails 4.0.0 gem and you're attempting to install
    it locally, but you don't have all the rails 4.0 dependencies installed, so
    that is why is failing.

    Instead of download the gem locally, please remove the local file and let
    RubyGems resolve the gems remotely and download the right version of the

    That should fix your issue.

  2. 2 Posted by Rajesh Gurbani on 17 Jul, 2013 06:20 AM

    Rajesh Gurbani's Avatar

    You are using rails 4.0.0 gem locally thats why its showing this error, install rails 4.0.0 globally it will resolve...

  3. Nick Quaranto closed this discussion on 18 Jul, 2013 12:18 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac