`lib_dirs_glob': undefined method `join' for "lib":String

foohey's Avatar

foohey

22 Oct, 2011 11:43 AM

Hi,
I'm getting this error from a fresh install of ruby 1.9.2 with default rubygems & updated rubygems (and debian squeeze ruby 1.8.7 & default rubygems)

Here the complete log:
ruby 1.9: http://pastie.org/2739968
ruby 1.8: http://pastie.org/2739826

Everything worked good before a "bundle update"
Searched 2hours this error without result

Thanks in advance

  1. Support Staff 1 Posted by Nick Quaranto on 04 Aug, 2012 06:47 PM

    Nick Quaranto's Avatar

    Sorry, this comment was buried in our spam inbox.

    Is this still happening?

  2. 2 Posted by Chris Van Patte... on 04 Sep, 2012 03:24 AM

    Chris Van Patten's Avatar

    I'm having (what I think is) a similar problem, whenever I run any gem commands. I'm working on writing my first gem, and this started happening after I installed it.

    Here's the output: http://pastie.org/4659979

  3. Support Staff 3 Posted by Nick Quaranto on 04 Sep, 2012 03:49 AM

    Nick Quaranto's Avatar

    Hey Chris.

    Sounds like you've got a corrupted gem spec, probably from the gem you're working on. My guess is that it's related to an old version of RubyGems in the old version of Ruby you're using. Whatever the gem name is, you should be able to cd into your gems dir (somewhere in ~/.rvm), kill its specifications/ and cache/ folders, and start over.

    The gem spec probably needs ["lib"] instead for some entry in there…you could also just jump into the specifications/ dir and manually edit it to fix it (and then rebuild your gem so this doesn't happen anymore).

    Overall this is a pretty gross bug…I'd try updating RubyGems once you're done, hopefully this won't happen in later versions.

    -Nick

  4. 4 Posted by Chris Van Patte... on 04 Sep, 2012 03:57 AM

    Chris Van Patten's Avatar

    Thanks Nick! Deleting the files in cache/ and specifications/ fixed it. I'll be more careful with my gemspecs going forward.

  5. Support Staff 5 Posted by Nick Quaranto on 07 Sep, 2012 03:13 AM

    Nick Quaranto's Avatar

    Woot!

  6. Nick Quaranto closed this discussion on 07 Sep, 2012 03:13 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 04:34 PM
30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM