rake release Hangs on New Gem Submission

Pedr's Avatar

Pedr

04 Jul, 2013 10:40 AM

I'm trying to release my first gem to Ruby Gems. The gem is working great locally.

I'm releasing it using:

$rake release

Which gives me this in the console:

example_gem 0.0.3 built to pkg/example_gem-0.0.1.gem 
Tagged v0.0.1
Pushed git commits and tags

Then the process hangs. I waited 20 mins, then cancelled.

When I tried to release again I got:

rake aborted!
This tag has already been committed to the repo.

So I assumed the gem had been successfully submitted, however 16 hours later, the gem is not under my account on Ruby Gems.

So I bumped the version and tried again using --trace, but the process hangs in the same place with only the following additions to output:

** Invoke release (first_time)
** Execute release
example_gem 0.0.3 built to pkg/example_gem-0.0.3.gem
Tagged v0.0.3
Pushed git commits and tags

What is going wrong?

Gem repo is here

  1. Support Staff 1 Posted by Nick Quaranto on 10 Jul, 2013 05:06 PM

    Nick Quaranto's Avatar

    Can you just gem push ? There's a entire guide on this here:

    http://guides.rubygems.org/publishing/

  2. Nick Quaranto closed this discussion on 10 Jul, 2013 05:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM
16 Oct, 2014 12:41 PM
06 Oct, 2014 02:30 PM