Gem::DependencyError

rkk's Avatar

rkk

18 Oct, 2011 01:51 PM

$ gem install rails ERROR: While executing gem ... (Gem::DependencyError)

Unable to resolve dependencies: rails requires activesupport (= 3.1.1), actionpack (= 3.1.1), activerecord (= 3.1.1), activeresource (= 3.1.1), actionmailer (= 3.1.1), railties (= 3.1.1)

Here is the error code.
I am curious about why this happen?
and also how to fix it.
my gem version 1.8.10, ruby version 1.9.2

  1. 1 Posted by rkk on 19 Oct, 2011 02:27 AM

    rkk's Avatar

    I've just solved it with a proxy.
    It's a network problem, not a RubyGems one.

  2. Support Staff 2 Posted by Nick Quaranto on 21 Oct, 2011 05:10 PM

    Nick Quaranto's Avatar

    Woot, closing!

  3. Nick Quaranto closed this discussion on 21 Oct, 2011 05:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 04:34 PM
30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM