Installing Problem

Nicole's Avatar

Nicole

11 Oct, 2011 03:32 AM

I am on a mac lion (newly reformatted).
I downloaded xcode, ran these commands.

sudo gem update --system (success)
then i typed in
sudo gem install rails and I get an error

Nicoles-MacBook-Pro:~ Nicole$ sudo gem install rails
Password:
ERROR: While executing gem ... (Gem::DependencyError)

Unable to resolve dependencies: sprockets requires hike (~> 1.2), tilt (!= 1.3.0, ~> 1.1); railties requires rdoc (~> 3.4); mail requires mime-types (~> 1.16), treetop (~> 1.4.8)

Nicoles-MacBook-Pro:~ Nicole$ gem sources -c
Removed specs cache Nicoles-MacBook-Pro:~ Nicole$ gem list rails

i googled around and came to this forum, and someone who had similar problem ask to type this, but the problem is still not resolved.

Nicoles-MacBook-Pro:~ Nicole$ gem instal rails --debug -V
Exception NameError' at /Library/Ruby/Site/1.8/rubygems/command_manager.rb:177 - uninitialized constant Gem::Commands::InstallCommand ExceptionGem::LoadError' at /Library/Ruby/Site/1.8/rubygems/dependency.rb:247 - Could not find psych (>= 1.2.1, ~> 1.2) amongst [rubygems-update-1.8.11]
Exception LoadError' at /Library/Ruby/Site/1.8/rubygems/custom_require.rb:36 - no such file to load -- psych ExceptionLoadError' at /Library/Ruby/Site/1.8/rubygems/custom_require.rb:62 - no such file to load -- psych
GET http://rubygems.org/latest_specs.4.8.gz
302 Found
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
Exception Errno::ENOENT' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - No such file or directory - /Users/Nicole/.gem/specs/rubygems.org%80 ExceptionErrno::ENOENT' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - No such file or directory -
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole
GET http://rubygems.org/quick/Marshal.4.8/rails-3.1.1.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/rails-3.1.1.gem...
200 OK
Exception Errno::ENOENT' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - No such file or directory - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 ExceptionErrno::ENOENT' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - No such file or directory -
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80 GET http://rubygems.org/specs.4.8.gz 302 Found GET http://production.s3.rubygems.org/specs.4.8.gz 200 OK ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80
GET http://rubygems.org/quick/Marshal.4.8/activesupport-3.1.1.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/activesupport-3...
200 OK
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 GET http://rubygems.org/quick/Marshal.4.8/actionpack-3.1.1.gemspec.rz 302 Found GET http://production.cf.rubygems.org/quick/Marshal.4.8/actionpack-3.1.1.gemspec.rz 200 OK ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8
GET http://rubygems.org/quick/Marshal.4.8/activerecord-3.1.1.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/activerecord-3....
200 OK
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 GET http://rubygems.org/quick/Marshal.4.8/activeresource-3.1.1.gemspec.rz 302 Found GET http://production.cf.rubygems.org/quick/Marshal.4.8/activeresource-3.1.1.gemspec.rz 200 OK ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8
GET http://rubygems.org/quick/Marshal.4.8/actionmailer-3.1.1.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/actionmailer-3....
200 OK
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 ^[[AGET http://rubygems.org/quick/Marshal.4.8/railties-3.1.1.gemspec.rz 302 Found GET http://production.cf.rubygems.org/quick/Marshal.4.8/railties-3.1.1.gemspec.rz 200 OK ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8
GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.0.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.0.g...
200 OK
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.2.gemspec.rz 302 Found GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.2.gemspec.rz 200 OK ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8
GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.3.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.3.g...
200 OK
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.5.gemspec.rz 302 Found GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.5.gemspec.rz 200 OK ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8
GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.7.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.7.g...
200 OK
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.9.gemspec.rz 302 Found GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.9.gemspec.rz 200 OK ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8
GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.10.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.10....
200 OK
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.11.gemspec.rz 302 Found GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.11.gemspec.rz 200 OK ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8
GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.12.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.12....
200 OK
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.13.gemspec.rz 302 Found GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.13.gemspec.rz 200 OK ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8
GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.14.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.14....
200 OK
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.15.gemspec.rz 302 Found GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.15.gemspec.rz 200 OK ExceptionErrno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8
GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.17.gemspec.rz
302 Found
GET http://production.cf.rubygems.org/quick/Marshal.4.8/bundler-1.0.17....
200 OK
Exception Errno::EEXIST' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/fileutils.rb:243 - File exists - /Users/Nicole/.gem/specs/rubygems.org%80/quick/Marshal.4.8 GET http://rubygems.org/quick/Marshal.4.8/bundler-1.0.18.gemspec.rz ExceptionEOFError' at /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/net/protocol.rb:135 - end of file reached
504 Gateway Timeout 50001
Exception Gem::RemoteFetcher::FetchError' at /Library/Ruby/Site/1.8/rubygems/remote_fetcher.rb:215 - bad response Gateway Timeout 50001 504 (http://rubygems.org/quick/Marshal.4.8/bundler-1.0.18.gemspec.rz) ExceptionGem::RemoteFetcher::FetchError' at /Library/Ruby/Site/1.8/rubygems/remote_fetcher.rb:235 - bad response Gateway Timeout 50001 504 (http://rubygems.org/quick/Marshal.4.8/bundler-1.0.18.gemspec.rz)
Error fetching remote data: bad response Gateway Timeout 50001 504 (http://rubygems.org/quick/Marshal.4.8/bundler-1.0.18.gemspec.rz)
Falling back to local-only install
Exception `Gem::DependencyError' at /Library/Ruby/Site/1.8/rubygems/dependency_installer.rb:153 - Unable to resolve dependencies: activeresource requires activemodel (= 3.1.1); activerecord requires activemodel (= 3.1.1), arel (~> 2.2.1), tzinfo (~> 0.3.29); rails requires bundler (~> 1.0); railties requires rake (>= 0.8.7), thor (~> 0.14.6), rack-ssl (~> 1.3.2), rdoc (~> 3.4); actionpack requires activemodel (= 3.1.1), rack-cache (~> 1.1), builder (~> 3.0.0), i18n (~> 0.6), rack (~> 1.3.2), rack-test (~> 0.6.1), rack-mount (~> 0.8.2), sprockets (~> 2.0.2), erubis (~> 2.7.0); actionmailer requires mail (~> 2.3.0); activesupport requires multi_json (~> 1.0)
ERROR: While executing gem ... (Gem::DependencyError)

Unable to resolve dependencies: activeresource requires activemodel (= 3.1.1); activerecord requires activemodel (= 3.1.1), arel (~> 2.2.1), tzinfo (~> 0.3.29); rails requires bundler (~> 1.0); railties requires rake (>= 0.8.7), thor (~> 0.14.6), rack-ssl (~> 1.3.2), rdoc (~> 3.4); actionpack requires activemodel (= 3.1.1), rack-cache (~> 1.1), builder (~> 3.0.0), i18n (~> 0.6), rack (~> 1.3.2), rack-test (~> 0.6.1), rack-mount (~> 0.8.2), sprockets (~> 2.0.2), erubis (~> 2.7.0); actionmailer requires mail (~> 2.3.0); activesupport requires multi_json (~> 1.0)
/Library/Ruby/Site/1.8/rubygems/dependency_installer.rb:153:in `gather_dependencies'
/Library/Ruby/Site/1.8/rubygems/dependency_installer.rb:267:in `install'
/Library/Ruby/Site/1.8/rubygems/commands/install_command.rb:121:in `execute'
/Library/Ruby/Site/1.8/rubygems/commands/install_command.rb:115:in `each'
/Library/Ruby/Site/1.8/rubygems/commands/install_command.rb:115:in `execute'
/Library/Ruby/Site/1.8/rubygems/command.rb:278:in `invoke'
/Library/Ruby/Site/1.8/rubygems/command_manager.rb:147:in `process_args'
/Library/Ruby/Site/1.8/rubygems/command_manager.rb:117:in `run'
/Library/Ruby/Site/1.8/rubygems/gem_runner.rb:65:in `run'
/usr/bin/gem:21
  1. Support Staff 1 Posted by Nick Quaranto on 04 Aug, 2012 06:47 PM

    Nick Quaranto's Avatar

    Sorry, this comment was buried in our spam inbox.

    Is this still happening?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM
16 Oct, 2014 12:41 PM
06 Oct, 2014 02:30 PM