ruby setup.rb CentOS5 Sytnax errors after untaring

afilice2's Avatar

afilice2

10 Oct, 2011 04:23 PM

ruby setup.rb

/lib/rubygems.rb:332: warning: parenthesize arguments for future version /lib/rubygems.rb:514: warning: parenthesize arguments for future version /lib/rubygems.rb:30: in 'require': ./lib/rubygems/deprecate.rb:53: syntax error (SyntaxError) define_method name do |*args, &block| #TODO: really works on 1.8.7? ./lib/rubygems/deprecate.rb:54: syntax error ./lib/rubygems/deprecate.rb:63: syntax error ./lib/rubygems/deprecate.rb:58: syntax error from ./lib/rubygems.rb:30 from setup.rb:27: in "requre"
from setup rb:27

  1. Support Staff 1 Posted by Eric Hodel on 10 Oct, 2011 05:36 PM

    Eric Hodel's Avatar

    You need to upgrade your ruby to 1.8.7 or use an older version of RubyGems (like the 1.3 series).

  2. Eric Hodel closed this discussion on 10 Oct, 2011 05:36 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM
16 Oct, 2014 12:41 PM