Error While executing gem ... (Errno::ENOENT)

Y's Avatar


10 Oct, 2011 09:50 AM

When I want to use gem I always get this error :
ERROR: While executing gem ... (Errno::ENOENT)

No such file or directory - //mycompanyserver.COM/_login$

What I should do to prevent that ?

  1. 1 Posted by Luis Lavena on 10 Oct, 2011 09:56 AM

    Luis Lavena's Avatar


    Looks like you're using Ruby on Windows inside a corporate environment, correct?

    Certain configurations of Windows set the user's home directory to a remote share.

    You can workaround that setting HOME environment variable.

    Please read the following in the Rubyinstaller troubleshooting page:

    Setting HOME to another directory (like your USERPROFILE) should correct the issue, of course, as long it doesn't contain spaces.

    Hope that helps.

  2. 2 Posted by Y on 10 Oct, 2011 10:00 AM

    Y's Avatar

    Thanks. I just replaced the "//mycompanyserver.COM/_login$" in my env variables by the disk letter pointing on this server and it works.

  3. 3 Posted by Luis Lavena on 10 Oct, 2011 10:05 AM

    Luis Lavena's Avatar

    Great to hear!

    Closing this out. Feel free to open another discussion if you have other issues!


  4. Luis Lavena closed this discussion on 10 Oct, 2011 10:05 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac