Problems after updating from rubygems 1.3.5

Purvez's Avatar

Purvez

22 Sep, 2011 05:43 PM

Hi

My system is ubuntu v10.04 with ruby 1.8 and rails 2.3.8.

I tried to install a gem 'whenever' which required rubygems version 1.3.6 or greater.

I tried the recommended approach to upgrading gem i.e. gem update --system but that complained that debian and ubuntu do not allow this. Looking around on Google I found the following:

gem install rubygems-update cd /var/lib/gems/1.9.1/bin sudo ./update_rubygems

I ran the above substituting 1.8 for 1.9.1 and that appeared to work. i.e. I could then run :

sudo gem install whenever

and that installed the current version of whenever.

However if I now try to start console using script/console I get an error message saying :

Missing the Rails 2.3.8 gem. Please gem install -v=2.3.8 rails, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.

It would appear that there is a gems directory under /var/lib/gems/... and another in my home directory $HOME/.gem/ruby/1.8/gems

The bulk of my gems are installed in /var/lib/gems etc but a few (the ones that I manually installed after ruby and rails were first installed on the system) are in $HOME/.gems etc. Included in the latter is the rubygems-update-1.8.10 gem.

The help I need is in undoing whatever has happened so that the system can go back to looking at /var/lib/gems and I can continue to use script/console. By the way the app itself seems to be unaffected by this although I haven't completed all the tests

If I run gem -v I get 1.8.10

Please help me get back to where I was or explain what I must do to rectify this problem.

Thanks

Purvez

  1. Nick Quaranto closed this discussion on 23 Sep, 2011 03:22 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM
18 Oct, 2014 08:39 PM
16 Oct, 2014 12:41 PM
06 Oct, 2014 02:30 PM