Unable to yank rbx-trepanning version 1.8.7-universal-rubinius-1.2

rockyb's Avatar

rockyb

14 Aug, 2011 12:44 PM

The version name 1.8.7-universal-rubinius-1.2 was added by mistake as a way to try to restrict installs to rubinius version 1.2 or greater which runs a 1.8.7 flavor of Ruby.

I'd like to yank it. and may have. But it still shows up on https://rubygems.org/gems/rbx-trepanning

Here is what happens when I try to yank it now:

$ gem yank rbx-trepanning -v 1.8.7
Yanking gem from RubyGems.org...
Pushing gem to https://rubygems.org...
The version 1.8.7 does not exist.
$ gem yank rbx-trepanning -v 1.8.7-universal-rubinius-1.2
ERROR:  While executing gem ... (ArgumentError)
    Illformed requirement ["1.8.7-universal-rubinius-1.2"]
$ gem yank rbx-trepanning -v 1.8.7-universal
ERROR:  While executing gem ... (ArgumentError)
    Illformed requirement ["1.8.7-universal"]

Please advise.

  1. Support Staff 2 Posted by Gabriel Horner on 26 Aug, 2011 03:56 AM

    Gabriel Horner's Avatar

    What happens if you try gem yank rbx-trepanning -v 1.8.7 --platform universal-rubinius-1.2 ? If that doesn't work, what gemcutter version and rubygems version are you running? We may need to report this to gemcutter

  2. 3 Posted by rockyb on 26 Aug, 2011 01:46 PM

    rockyb's Avatar

    That worked - thanks! When I go to https://rubygems.org/gems/rbx-trepanning now though I see 0.0.1 listed by default, rather than 0.0.8 :-/ Perhaps that will right itself eventually? If not, I can load up the next release.

  3. Support Staff 4 Posted by Gabriel Horner on 27 Aug, 2011 05:36 AM

    Gabriel Horner's Avatar

    Glad the yank worked out. The 0.0.1 listing is a bug we'll need to fix. I've started an issue to look into it, https://github.com/rubygems/rubygems.org/issues/341

  4. Gabriel Horner closed this discussion on 27 Aug, 2011 05:36 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Aug, 2014 06:23 PM
28 Aug, 2014 07:18 PM
27 Aug, 2014 12:03 PM
26 Aug, 2014 07:09 PM
26 Aug, 2014 07:07 PM