teleport gem always one behind

Adam Doppelt's Avatar

Adam Doppelt

03 Aug, 2011 09:37 PM

Whenever I publish a new version of my gem the rubygems page always shows the SECOND TO LAST version of the gem:

https://rubygems.org/gems/teleport

Note that I just pushed rc1, but the page shows beta5 as the preferred version.

Naturally, I've tried to fix this by publishing new versions, yanking, etc. to no avail. rc1 was just my latest attempt to fix the problem. I'm getting some serious version inflation here. Please stop me before I prematurely get to 2.0!

  1. Support Staff 2 Posted by Nick Quaranto on 03 Aug, 2011 09:49 PM

    Nick Quaranto's Avatar

    I'm not sure if this is an RG bug or not, but here's why:

    [Gem::Version.new("1.0.0.rc.1"), Gem::Version.new("1.0.0.beta5")].sort.map(&:to_s)
     => ["1.0.0.beta5", "1.0.0.rc.1"] 
    

    Besides the bug, do you need so many "beta" and "rc" gems especially when there hasn't been a 1.0 and you're probably the only user right now? This sounds like you're sending a lot of effort copying what Rails does for no reason.

  2. 3 Posted by Adam Doppelt on 03 Aug, 2011 09:53 PM

    Adam Doppelt's Avatar

    Hi Nick, nice to meet you. I advanced to rc1 in a vain attempt to fix
    the problem. I had the same bug with beta3, beta4 and beta5 which I
    pushed today. In fact, my last five git pushes are all vain attempts
    to make the right version show up. I don't want to have so many
    versions, believe me!

    Is there a way to fix it? I'm happy to start over somehow if that's
    the easiest fix.

    Adam

  3. Support Staff 4 Posted by Nick Quaranto on 03 Aug, 2011 10:01 PM

    Nick Quaranto's Avatar

    Yank them all and start over at 0.0.0 or 0.1.0. You're never going to run out of version numbers.

  4. 5 Posted by Adam Doppelt on 03 Aug, 2011 10:09 PM

    Adam Doppelt's Avatar

    I was skeptical because that's exactly what I just did a bunch of
    times during my artificial march to rc1. But it worked. Moving to
    1.0.0 solved it! Thanks for your help!

  5. Gabriel Horner closed this discussion on 07 Aug, 2011 03:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Aug, 2014 06:23 PM
28 Aug, 2014 07:18 PM
27 Aug, 2014 12:03 PM
26 Aug, 2014 07:09 PM
26 Aug, 2014 07:07 PM