gem update and ruby setup --help are both failing

Kathy's Avatar

Kathy

12 Jul, 2011 01:53 AM

Hi,
I'm a ruby newby, at least as far as ruby admin is concerned (I've done some programming in ruby but I'm getting spanked trying to update ruby and gems on a new server).

Here's the problem, in a nutshell:

(1) Tried to run gem update --system (and before that, tried gem install [ANYTHING]), but getting this error:

ERROR: While executing gem ... (Gem::RemoteSourceException)
HTTP Response 302 fetching http://gems.rubyforge.org/yaml

(2) Tried running ruby setup.rb --help to understand how/whether I could update the source URL, and got this error:

erisaesq:rubygems-1.8.5 kathy$ ruby setup.rb --help
./lib/rubygems.rb:334: warning: parenthesize argument(s) for future version ./lib/rubygems.rb:511: warning: parenthesize argument(s) for future version ./lib/rubygems/dependency_list.rb:8:in `require': ./lib/rubygems/deprecate.rb:53: syntax error, unexpected ',', expecting '|' (SyntaxError) ... define_method name do |*args, &block| # TODO: really works ...

                          ^

./lib/rubygems/deprecate.rb:54: syntax error, unexpected tCONSTANT, expecting '}' ./lib/rubygems/deprecate.rb:63: syntax error, unexpected kEND, expecting '}' ./lib/rubygems/deprecate.rb:68: syntax error, unexpected kEND, expecting '}'

from ./lib/rubygems/dependency_list.rb:8
from ./lib/rubygems.rb:29:in `require'
from ./lib/rubygems.rb:29
from setup.rb:27:in `require'
from setup.rb:27

Question: what's up with my ruby config?

  1. Support Staff 2 Posted by Luis Lavena on 12 Jul, 2011 02:32 AM

    Luis Lavena's Avatar

    Hello,

    Please adjust your RubyGems sources to point to rubygems.org instead of gems.rubyforge.org, which is old and the version of RubyGems you're using do not support redirect (HTTP 302)

    See gem help sources or manually edit .gemrc file in your home directory.

    Also, what version of Ruby are you trying to update to RubyGems 1.8.5? RubyGems requires minimum Ruby 1.8.7.

  2. 3 Posted by Kathy on 12 Jul, 2011 02:37 AM

    Kathy's Avatar

    Many thanks for the fast reply!

    I'll update the RubyGems source URL asap.

    Also, re ruby: I'm in the process of updating ruby to 1.8.7, so that should resolve any RubyGems issues with the older ruby version.

    Thanks again!

  3. Nick Quaranto closed this discussion on 29 Jul, 2011 03:28 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac