talib_ruby on Debian problem v2.0

pharchoma's Avatar

pharchoma

17 Jun, 2011 10:14 PM

Unfortunately, my last thread was closed a bit prematurely, IMHO.

Eric was right that I was missing a lib. I installed ta-lib-dev, and now I get:
checking for TA_Initialize() in -lta_lib… yes

However, all of the other errors subsequent to that line still exist. Does anybody have any insight into

talib.c:2:25: error: ta_abstract.h: No such file or directory

I'm not familiar enough with this process and some of these libraries to know what exactly is wrong. I'm not sure if this is part of another library, something that needs to be linked to, or something else. I can't find the file on my system, nor am I able to find much info via Google to make this issue go away.

I appreciate any help (and perhaps leaving the thread open beyond one reply so I don't gum up the board with duplicate threads).

Thanks!

  1. Support Staff 2 Posted by Eric Hodel on 17 Jun, 2011 10:38 PM

    Eric Hodel's Avatar

    Again, this is not an issue with rubygems, it is an issue with the gem you are using. You will need to consult the gem's documentation or contact the author if you want help installing it as it has compiled components.

    This site is for problems with rubygems itself, not for help with published gems. The responsibility for support for a published gem belongs to the author. You should try consulting the author by filing a ticket: http://github.com/rivella50/talib-ruby

  2. Eric Hodel closed this discussion on 17 Jun, 2011 10:38 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac