How to download WATIR 1.6

Chrysta Stotts's Avatar

Chrysta Stotts

26 Feb, 2010 04:22 PM

I downloaded the executables and have installed Ruby 1.8.6-26 and RubyGems 1.3.5. Now I need to download Watir 1.6.0 but when I click the download link for Watir from this site I get a screen with random characters on it. I need to run Watir on a network that doesn't have internet connectivity (i.e., the command gem install watir doesn't work). How can I download Watir 1.6.0 from the internet and install it on a system without network connectivity?

  1. Support Staff 2 Posted by Eric Hodel on 26 Feb, 2010 06:25 PM

    Eric Hodel's Avatar

    You should be able to right click on the link and select "download".

    The easiest way is to gem install watir -i tmp_gems/ then grab all the gems from tmp_gems/cache/.

  2. 3 Posted by Chrysta Stotts on 26 Feb, 2010 07:43 PM

    Chrysta Stotts's Avatar

    But can't you only enter the command you suggest after first installing Ruby and RubyGems? I didn't install them on the computer with internet connectivity. I downloaded them then installed them on another non-networked machine.

    It looks like the right-click option may work. As soon as I get download approval from our security folks, I'll try and let you know.

    Thanks!

  3. Support Staff 4 Posted by Eric Hodel on 26 Feb, 2010 07:46 PM

    Eric Hodel's Avatar

    Yes.

    If you manually download you'll need to also download all the dependencies.

  4. 5 Posted by Chrysta Stotts on 01 Mar, 2010 08:58 PM

    Chrysta Stotts's Avatar

    No dice.

    To recap, I downloaded Ruby 1.8.6-26 and RubyGems 1.3.5, transferred the files to the test network (which does NOT have internet connectivity) and installed them. Now I'm attempting to get the Watir gem. I right-clicked on the download link but the file that I saved was named watir-1.6.5.htm. I saved it anyway and copied it over the the test network. But when I run the command (gem install watir OR gem install watir -i tmp_gems/) the error states:
    ERROR: http://rubygems.org/ does not appear to be a repository
    ERROR: could not find gem watir locally or in a repository

    What am I doing wrong?

  5. 6 Posted by Chrysta Stotts on 01 Mar, 2010 09:07 PM

    Chrysta Stotts's Avatar

    Is there an FTP site or some other way I can download the file? A way to get around needing the gem? All the other dependencies are in place.

  6. Support Staff 7 Posted by Nick Quaranto on 13 Mar, 2010 06:38 PM

    Nick Quaranto's Avatar

    As far as I know, this is due to an incorrect mimetype on our uploads to S3. I'll be looking into correcting this for our gems that currently are up on S3, and how to prevent this going forward.

  7. 8 Posted by Suresh Palli on 22 Mar, 2010 06:42 PM

    Suresh Palli's Avatar

    Has this been resolved, I'm still getting this error. Is there any work around.

  8. Support Staff 9 Posted by Eric Hodel on 22 Mar, 2010 08:54 PM

    Eric Hodel's Avatar

    Right-click on the download link and select download, or option-click if you're on a Mac.

  9. 10 Posted by Chrysta Stotts on 15 Apr, 2010 03:58 PM

    Chrysta Stotts's Avatar

    Again, the reason for my post is that when I select "Download" I see random bytes (as demonstrated in the attached file). Incidentally, when I right-click the download link, there isn't a download option in the menu. Instead, I selected 'Save Target As...' but that yielded the same result.

    Post #7 above seems to indicate that it's not me, that it's an error due to an incorrect mimetype. What is the ETA on resolution?

  10. 11 Posted by rahul on 16 Apr, 2010 01:30 PM

    rahul's Avatar

    Is this issue fixed. Even i am getting the same problem at my work place but only when i am behind a gateway server which requires basic authentication(userid:password) for internet access.

    I tried "gem install watir" on my home PC and it worked like a charm. OS is Windows 7 Home Premium. The command window was opened as "Run as Administrator".

    Which such a behavior.??

  11. 12 Posted by Rahul on 16 Apr, 2010 02:45 PM

    Rahul's Avatar

    See installation log as seen in command window when i am behind a gateway which requires authentication (username : password)

    i have set HTTP_PROXY environment variable as

    http://USERID:PASSWORD@GATEWAYURL:PORTNO

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\prabhak>gem update --system
    Updating RubyGems...
    Need to update 1 gems from http://gems.rubyforge.org
    . complete
    Attempting remote update of rubygems-update
    Successfully installed rubygems-update-1.3.6
    Installing ri documentation for rubygems-update-1.3.6...
    Installing RDoc documentation for rubygems-update-1.3.6...
    Could not find main page README
    Could not find main page README
    Could not find main page README
    Could not find main page README
    Updating version of RubyGems to 1.3.6
    Installing RubyGems 1.3.6
    RubyGems 1.3.6 installed

    === 1.3.6 / 2010-02-17

    NOTE:

    http://rubygems.org is now the default source for downloading gems.

    You may have sources set via ~/.gemrc, so you should replace
    http://gems.rubyforge.org with http://rubygems.org

    http://gems.rubyforge.org will continue to work for the forseeable future.

    New features:

    • gem commands
      • Added gem push and gem owner for interacting with modern/Gemcutter sources
      • gem dep now supports --prerelease.
      • gem fetch now supports --prerelease.
      • gem server now supports --bind. Patch #27357 by Bruno Michel.
      • gem rdoc no longer overwrites built documentation. Use --overwrite force rebuilding. Patch #25982 by Akinori MUSHA.
    • Captial letters are now allowed in prerelease versions.

    Bug fixes:

    • Development deps are no longer added to rubygems-update gem so older versions can update sucessfully.
    • Installer bugs:
      • Prerelease gems can now depend on non-prerelease gems.
      • Development dependencies are ignored unless explicitly needed. Bug #27608 by Roger Pack.
    • gem commands
      • gem which now fails if no paths were found. Adapted patch #27681 by Caio Chassot.
      • gem server no longer has invalid markup. Bug #27045 by Eric Young.
      • gem list and friends show both prerelease and regular gems when --prerelease --all is given
    • Gem::Format no longer crashes on empty files. Bug #27292 by Ian Ragsdale.
    • Gem::GemPathSearcher handles nil require_paths. Patch #27334 by Roger Pack.
    • Gem::RemoteFetcher no longer copies the file if it is where we want it. Patch #27409 by Jakub ┼á┼Ñastn├╜.

    Deprecation Notices:

    • lib/rubygems/timer.rb has been removed.
    • Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010.
    • Bulk index update is no longer supported.
    • Gem::manage_gems was removed in 1.3.3.
    • Time::today was removed in 1.3.3.

    RubyGems installed the following executables:

        c:/ruby/bin/gem
    

    RubyGems system software updated

    C:\Documents and Settings\prabhak>gem install watir
    ERROR: http://rubygems.org/ does not appear to be a repository
    ERROR: could not find gem watir locally or in a repository

    C:\Documents and Settings\prabhak>

  12. 13 Posted by Praj on 03 Jul, 2010 10:13 AM

    Praj's Avatar

    Dear,

    I am not bale to install watir on my home pc.

    C:>ruby -v
    ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]

    C:>gem -v
    1.3.7

    Error:
    C:>gem install watir
    ERROR: http://rubygems.org/ does not appear to be a repository
    ERROR: Could not find a valid gem 'watir' (>= 0) in any repository

    Pls help...

  13. 14 Posted by doss on 03 Aug, 2010 10:51 AM

    doss's Avatar

    Dear,
    Please give me a hand, --> How to let http://rubygems.org/ DOES appear as a repository? I can't install/update any gems. May I point the link to any other sites, instead of this http://rubygems.org/ ??

    Example:
    gems>gem install nokogiri
    ERROR: http://rubygems.org/ does not appear to be a repository
    ERROR: Could not find a valid gem 'nokogiri' (>= 0) in any repository

    BTW, i am using gem1.3.7, in windows, and behind a firewall, without proxy server, but with automatic configuration script.

  14. Support Staff 15 Posted by Eric Hodel on 03 Aug, 2010 09:19 PM

    Eric Hodel's Avatar

    Praj, doss, please open a new issue. Do not hijack this one.

  15. Nick Quaranto closed this discussion on 18 Mar, 2011 08:19 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Aug, 2014 06:23 PM
28 Aug, 2014 07:18 PM
27 Aug, 2014 12:03 PM
26 Aug, 2014 07:09 PM
26 Aug, 2014 07:07 PM