Error running setup.rb for rubygems 1.8.1 on CentOS 4

icarovts's Avatar


17 May, 2011 02:21 PM

I'm trying to install rubygems 1.8.1, on a Linux CentOS 4 wich has installed ruby 1.8.1 succesfully.
I got the rubygems package by wget on the follow link:
By running 'ruby setup.rb' on rubygems-1.8.1 directory, I got this error:

./lib/rubygems.rb:334: warning: parenthesize argument(s) for future version
./lib/rubygems.rb:511: warning: parenthesize argument(s) for future version
./lib/rubygems/dependency_list.rb:8:in `require': ./lib/rubygems/deprecate.rb:53: syntax error (SyntaxError)
       define_method name do |*args, &block| # TODO: really works on 1.8.7?
./lib/rubygems/deprecate.rb:54: syntax error
./lib/rubygems/deprecate.rb:63: syntax error
./lib/rubygems/deprecate.rb:68: syntax error    from ./lib/rubygems/dependency_list.rb:8
        from ./lib/rubygems.rb:29:in `require'
        from ./lib/rubygems.rb:29
        from setup.rb:24:in `require'
        from setup.rb:24

Is it a version error of my Ruby? What type of problem can be?

Thanks!!!! \o

  1. 1 Posted by Maurício Szabo on 17 May, 2011 02:56 PM

    Maurício Szabo's Avatar

    Ruby 1.8.1 is AGES old. If you cant install Ruby 1.8.7 (or 1.9.2) with yum, try to compile it from source, or to install it with RVM.

    Rails, Rubygems, ActiveSupport and ActiveRecord have all dropped ruby 1.8.6 (and older) support by now...

  2. Support Staff 2 Posted by Nick Quaranto on 27 May, 2011 12:19 AM

    Nick Quaranto's Avatar

    Yes, definitely upgrade Ruby. Please use RVM too!

  3. Nick Quaranto closed this discussion on 27 May, 2011 12:19 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac