Unable to update/install gems

mgbeers's Avatar

mgbeers

11 May, 2011 07:15 PM

I am getting the error below:

ERROR: http://rubygems.org/ does not appear to be a repository
ERROR: Could not find a valid gem 'rails' (>= 0) in any repository

The gem env gives me the following:

RubyGems Environment:
- RUBYGEMS VERSION: 1.3.7 - RUBY VERSION: 1.8.7 (2008-08-11 patchlevel 72) [i386-mswin32] - INSTALLATION DIRECTORY: c:/ruby/lib/ruby/gems/1.8 - RUBY EXECUTABLE: c:/ruby/bin/ruby.exe - EXECUTABLE DIRECTORY: c:/ruby/bin - RUBYGEMS PLATFORMS:

- ruby
- x86-mswin32-60
  • GEM PATHS:
    • c:/ruby/lib/ruby/gems/1.8
    • Z:/.gem/ruby/1.8
  • GEM CONFIGURATION:
    • :update_sources => true
    • :verbose => true
    • :benchmark => false
    • :backtrace => false
    • :bulk_threshold => 1000
  • REMOTE SOURCES:
  1. Support Staff 2 Posted by Luis Lavena on 11 May, 2011 07:44 PM

    Luis Lavena's Avatar
  2. Luis Lavena closed this discussion on 11 May, 2011 07:44 PM.

  3. mgbeers re-opened this discussion on 11 May, 2011 07:54 PM

  4. 3 Posted by mgbeers on 11 May, 2011 07:54 PM

    mgbeers's Avatar

    Actually this is what I've been trying to do all day. I am confused by the actual command reference, for one thing. Do I type the [no-] or is that referring to something else? I know what my http proxy server is and it's port as I have it working fine in my browser. What I've tried last:

    C:>gem install heroku --http-proxy http://[the url from my browser]:8080, -p
    ERROR: While executing gem ... (OptionParser::InvalidArgument)

    invalid argument: --http-proxy http://access.lb.ssa.gov:8080,
    
  5. 4 Posted by Matthew Beers on 11 May, 2011 07:57 PM

    Matthew Beers's Avatar

    I have

    On Wed, May 11, 2011 at 3:45 PM, Luis Lavena <
    [email blocked]> wrote:

  6. 5 Posted by Matthew Beers on 11 May, 2011 07:59 PM

    Matthew Beers's Avatar

    I did not get much of an answer from you here and you closed the
    discussion. Why? The problem isn't one that I cannot figure out how to
    find the answers that you referred me to already, it's that I've already
    been there, done that! You should at least give the poster a chance to
    reply to that effect before closing it hastily.

    On Wed, May 11, 2011 at 3:45 PM, Luis Lavena <
    [email blocked]> wrote:

  7. Support Staff 6 Posted by Luis Lavena on 11 May, 2011 09:18 PM

    Luis Lavena's Avatar

    I did close the discussion because is a duplication of other discussion on the same thing: proxy

    gem install heroku --http-proxy=http://user:password@server:port/ is the correct syntax.

    If you had HTTP_PROXY environment variable set, then --no-http-proxy will disable that.

    The no part is the negation of the first.

    Either you can use the --http-proxy option or set HTTP_PROXY environment variable.

    Please check again the command syntax and the URI syntax I shown above.

    Let me know if that doesn't work.

  8. 7 Posted by Matthew Beers on 11 May, 2011 09:20 PM

    Matthew Beers's Avatar

    Thank you for getting back to me. I will let you know, if you like.. if
    this works or not. I feel like I've tried every angle though ;)

    On Wed, May 11, 2011 at 5:18 PM, Luis Lavena <
    [email blocked]> wrote:

  9. 8 Posted by Matthew Beers on 11 May, 2011 09:27 PM

    Matthew Beers's Avatar

    I'm not sure why but it just doesn't work

    our proxy server is like this: access.[a government org].gov:80

  10. Support Staff 9 Posted by Luis Lavena on 11 May, 2011 09:31 PM

    Luis Lavena's Avatar

    What protocol? HTTP?

    the URL needs to be http://access.[goverment org].gov:80/

    It is important the format.

    Please provide a Pastie or Gist that shows the full output of the command:

    gem install heroku --http-proxy=http://access.[a government org].gov:80/ --debug -V

  11. 10 Posted by Matthew Beers on 11 May, 2011 09:40 PM

    Matthew Beers's Avatar

    pastie:
    http://pastie.org/1890714

    On Wed, May 11, 2011 at 5:31 PM, Luis Lavena <
    [email blocked]> wrote:

  12. 11 Posted by Matthew Beers on 11 May, 2011 09:41 PM

    Matthew Beers's Avatar

    updated the pastie so as not to reveal the actual domain or organization.

  13. Support Staff 12 Posted by Luis Lavena on 11 May, 2011 09:43 PM

    Luis Lavena's Avatar

    You're getting a Forbbiden (403) response from the proxy:

    GET http://rubygems.org/latest_specs.4.8.gz
    403 Forbidden
    Exception `Gem::RemoteFetcher::FetchError' at c:/ruby/lib/ruby/site_ruby/1.8/rub
    ygems/remote_fetcher.rb:300 - bad response Forbidden 403 (http://rubygems.org/la
    test_specs.4.8.gz)
    

    This is most likely because the proxy requires an username and a password that you aren't providing in the URI for http-proxy.

    Please see my previous comment on the URI structure for http proxy, add your username and password and try again.

  14. Support Staff 13 Posted by Luis Lavena on 11 May, 2011 09:44 PM

    Luis Lavena's Avatar

    BTW, is completely irrelevant for what organization you work for, what matters is help you solve the issue, which seems to be associated with not authorized proxy.

  15. 14 Posted by Matthew Beers on 11 May, 2011 09:44 PM

    Matthew Beers's Avatar

    Ok i will try that, not sure if I have the right format for it since our
    logins are domain\username

    On Wed, May 11, 2011 at 5:43 PM, Luis Lavena <
    [email blocked]> wrote:

  16. Support Staff 15 Posted by Luis Lavena on 23 May, 2011 09:37 PM

    Luis Lavena's Avatar

    Hello,

    I haven't heard back from you you in 2 weeks. Did you manage to solve the correct URI of your corporate proxy?

    Please respond to this and let us know.

    Going to close this in a few days if no response is given.

    Thank you.

  17. 16 Posted by Cesar Garcia on 30 Jan, 2014 04:16 PM

    Cesar Garcia's Avatar

    I had exactly the same problem and using this format of the proxy worked for me on 1.3.6

    gem install heroku --http-proxy=http://user:password@server:port/

    Using the environment variables did not worked at all.

  18. Nick Quaranto closed this discussion on 16 Apr, 2014 07:27 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Aug, 2014 06:23 PM
28 Aug, 2014 07:18 PM
27 Aug, 2014 12:03 PM
26 Aug, 2014 07:09 PM
26 Aug, 2014 07:07 PM