Invalid gemspec with "invalid date format in specification"

peter.royal's Avatar

peter.royal

26 Apr, 2011 12:33 PM

Building a gem with Ruby 1.9.2, rubygems 1.7.2

And then using the gem on Ruby 1.8.7

I get:

Invalid gemspec in [my.gemspec]: invalid date format in specification: "2011-04-25 00:00:00.000000000Z"

  1. 2 Posted by peter.royal on 26 Apr, 2011 12:35 PM

    peter.royal's Avatar

    This is a pull request for this problem:

    https://github.com/rubygems/rubygems/pull/57

  2. 3 Posted by peter.royal on 03 May, 2011 12:24 PM

    peter.royal's Avatar

    a workaround is to force syck when building the gem:

    YAML::ENGINE.yamler = 'syck'

  3. Support Staff 4 Posted by Ryan Davis on 19 May, 2011 12:32 AM

    Ryan Davis's Avatar

    This is now fixed and will go out in 1.8.3 or 1.9.0, whichever happens first.

  4. Ryan Davis closed this discussion on 19 May, 2011 12:32 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac