errors when running ruby setup.rb

Paul Bourget's Avatar

Paul Bourget

25 Apr, 2011 03:04 PM

Using CentOS 5.4 I did a yum install ruby (1.8.5-5.el5_4.8)
I loaded the default version of rubygems (1.7.2)

I get an error when running ruby setup.rb. Any suggestions?

[***@vizitdb rubygems-1.7.2]# ruby setup.rb ./lib/rubygems/custom_require.rb:53: warning: parenthesize argument(s) for future version ./lib/rubygems/custom_require.rb:56:in require': undefined methodend_with?' for no such file to load -- Win32API (NoMethodError)

from ./lib/rubygems/config_file.rb:55
from ./lib/rubygems/custom_require.rb:36:in `gem_original_require'
from ./lib/rubygems/custom_require.rb:36:in `require'
from ./lib/rubygems/gem_runner.rb:8
from ./lib/rubygems/custom_require.rb:36:in `gem_original_require'
from ./lib/rubygems/custom_require.rb:36:in `require'
from setup.rb:25
  1. Support Staff 1 Posted by Luis Lavena on 25 Apr, 2011 05:03 PM

    Luis Lavena's Avatar

    RubyGems 1.7.2 requires Ruby 1.8.7 or greater.

  2. Luis Lavena closed this discussion on 25 Apr, 2011 05:03 PM.

  3. Paul Bourget re-opened this discussion on 25 Apr, 2011 05:20 PM

  4. 2 Posted by Paul Bourget on 25 Apr, 2011 05:20 PM

    Paul Bourget's Avatar

    I installed ruby 1.8.7 compiling from source. Yum list still shows 1.8.5. Do I have to remove the old version using yum and then do the make install again?

  5. 3 Posted by Paul Bourget on 25 Apr, 2011 05:28 PM

    Paul Bourget's Avatar

    I opened a new shell and setup.rb now works. Yum still shows 1.8.5 though.

  6. Nick Quaranto closed this discussion on 08 May, 2011 05:08 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 04:34 PM
30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM