can install rubygems

james jones's Avatar

james jones

05 Apr, 2011 03:09 PM

any idea how to fix this? I am running centos 5.5 with ruby installed from rpm.

 [root@xxxxxxxx rubygems-1.7.1]# ruby setup.rb 
./lib/rubygems/custom_require.rb:53: warning: parenthesize argument(s) for future version
./lib/rubygems/custom_require.rb:56:in `require': undefined method `end_with?' for "no such file to load -- Win32API":String (NoMethodError)
         from ./lib/rubygems/config_file.rb:55
         from ./lib/rubygems/custom_require.rb:36:in `gem_original_require'
         from ./lib/rubygems/custom_require.rb:36:in `require'
         from ./lib/rubygems/gem_runner.rb:8
         from ./lib/rubygems/custom_require.rb:36:in `gem_original_require'
         from ./lib/rubygems/custom_require.rb:36:in `require'
         from setup.rb:25
  1. 1 Posted by james jones on 05 Apr, 2011 03:10 PM

    james jones's Avatar

    oops I messed up the title.

  2. Support Staff 2 Posted by Luis Lavena on 05 Apr, 2011 03:22 PM

    Luis Lavena's Avatar

    Ruby 1.8.6 is not supported by newer RubyGems, you need at least Ruby 1.8.7 to use it.

  3. Luis Lavena closed this discussion on 05 Apr, 2011 03:22 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Oct, 2014 04:34 PM
30 Oct, 2014 02:46 PM
28 Oct, 2014 09:51 AM
23 Oct, 2014 05:37 PM
21 Oct, 2014 10:47 AM