ERROR: http://rubygems.org/ does not appear to be a repository

Rupert's Avatar

Rupert

05 Apr, 2011 04:23 AM

Today I tried running bundle install (after adding the "autorefresh" gem to my Gemfile), and got the following error:

Could not find gem 'autorefresh (>= 0, runtime)' in any of the gem sources listed in your Gemfile.

I then tried to install the gem with sudo gem install autorefresh and got the following:

ERROR: http://rubygems.org/ does not appear to be a repository

I have googled around and discovered that this is usually a proxy issue. However, I have been able to access rubygems just fine over the last few months and, as far as I know, I have made no relevant changes to my network settings during that time. Additionally, I can still ping rubygems.org just fine.

I also tried to updating rubygems (using apt-get) but I still get the same problem.

Is there anything else I can do to try and solve this?

In case it helps, I am running my development environment on Ubuntu 10.10 inside a virtual box on a Windows 7 host.

  1. 2 Posted by Rupert on 05 Apr, 2011 04:25 AM

    Rupert's Avatar

    Sorry I forgot to mention that my rubygems version is 1.3.7

  2. 3 Posted by Rupert on 05 Apr, 2011 04:46 AM

    Rupert's Avatar

    I've realized that the "up to date" version installed by apt-get was not all up to date. I've now installed the latest version and it works fine.

    I should have know. Sorry for the bother!

  3. Nick Quaranto closed this discussion on 20 Apr, 2011 12:23 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac