Cannot install RubyGems

De Herdt Arne's Avatar

De Herdt Arne

04 Apr, 2011 11:46 AM

Hello,

I've downloaded ruby and RubyGems because I need to work on a new project related to Lucien, and was planning to use the Feret gem for this to make my work a bit easier.
I managed to install Ruby and the RubyGem through the installer, but when I try to run the install command to get the ferret gem, it's not working.

I've downloaded the ferret gem manually and placed in a directory, and then tried to install the gem with the following command:

C:\Users\arne.de.herdt\Downloads>gem install ferret-0.11.6.gem

This produces the following error however:

ERROR:  While executing gem ... (Errno::ENOENT)
No such file or directory - H:/

What can I do to solve this problem, and what is causing it in the first place?

C:\Users\arne.de.herdt\Downloads>gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.7.1
  - RUBY VERSION: 1.9.2 (2011-02-18 patchlevel 180) [i386-mingw32]
  - INSTALLATION DIRECTORY: C:/Ruby/lib/ruby/gems/1.8
  - RUBY EXECUTABLE: C:/Ruby/bin/ruby.exe
  - EXECUTABLE DIRECTORY: C:/Ruby/lib/ruby/gems/1.8/bin
  - RUBYGEMS PLATFORMS:
  - ruby
  - x86-mingw32
- GEM PATHS:
     - C:/Ruby/lib/ruby/gems/1.8
     - C:/Ruby/lib/ruby/gems/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/`
  1. 2 Posted by De Herdt Arne on 04 Apr, 2011 12:00 PM

    De Herdt Arne's Avatar

    Also,
    I'd like to add the following additional debug information. Perhaps it can help in solving the problem I'm encountering:

    C:\Windows\system32>gem install ferret --debug
    Exception `NameError' at   C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/command_manager.rb:163 - uninitialized constant Gem::Commands::InstallCommand
    Exception `Errno::ENOENT' at C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:54 - No such file or directory - H:/
    ERROR:  While executing gem ... (Errno::ENOENT)
        No such file or directory - H:/
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:54:in `stat'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:54:in `initialize'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:43:in `new'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/spec_fetcher.rb:43:in `fetcher'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/dependency_installer.rb:108:in `find_gems_with_sources'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/dependency_installer.rb:228:in `find_spec_by_name_and_version'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/dependency_installer.rb:260:in `install'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/commands/install_command.rb:120:in `block in execute'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/commands/install_command.rb:115:in `each'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/commands/install_command.rb:115:in `execute'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/command.rb:278:in `invoke'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/command_manager.rb:133:in `process_args'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/command_manager.rb:103:in `run'
            C:/Ruby/lib/ruby/site_ruby/1.9.1/rubygems/gem_runner.rb:64:in `run'
            C:/Ruby/bin/gem:21:in `<main>'
    
  2. 3 Posted by De Herdt Arne on 04 Apr, 2011 12:06 PM

    De Herdt Arne's Avatar

    Nevermind, seems I solved it.
    I was running the shell with elevated permissions as Administrator.
    When I ran it normally, it worked fine.

    Can be closed.

  3. Support Staff 4 Posted by Luis Lavena on 04 Apr, 2011 06:02 PM

    Luis Lavena's Avatar

    Hello, this is caused by one environment variable (most of the time HOME, USERPROFILE or HOMEDRIVE and HOMEPATH)

    Please verify that none of these variables point to H:, you can do that using SET var (replacing var with one of the variables I mentioned before)

    Most of the times this happens with mapped network drives or user-configured home directories.

    Closing this out since seems you figure it out already.

  4. Luis Lavena closed this discussion on 04 Apr, 2011 06:02 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

16 Apr, 2014 09:28 PM
16 Apr, 2014 08:29 PM
16 Apr, 2014 08:28 PM
16 Apr, 2014 08:26 PM
16 Apr, 2014 08:23 PM